What's new

Thchardcore

Enthusiast
Joined
Mar 14, 2019
Messages
235
Reaction score
172
Location
Pelosiville Commiefornia
Wish I had your troubleshooting knowledge. Impressive to say the least.
 

ShootTheCore

Enlightened
Joined
Jan 20, 2016
Messages
1,842
Reaction score
2,831
Location
Logan UT
Wish I had your troubleshooting knowledge. Impressive to say the least.

Thank you for the compliment. I learned a TON from reading the PCB repair logs that @caius , @yavuzg , Porchy, Bryan McPhail and others have written - I'm just trying to follow in their footsteps and document everything publicly as best I can. :thumbsup:
 

ShootTheCore

Enlightened
Joined
Jan 20, 2016
Messages
1,842
Reaction score
2,831
Location
Logan UT
The KNA6034201 reproductions from @caius arrived and FINALLY the board set is working 100% with no jailbars!

IMG_8988.jpgIMG_8991.jpgIMG_8990.jpgIMG_8989.jpg

I ran the board for 24 hours as a "soak test" just to make sure that everything was solid. For good measure, I tried swapping in each of the original KN customs one at a time just to see if one of them was good, but unfortunately both custom chips have issues.

In the end, I ended up replacing 14 failed chips across both the middle and bottom boards.
IMG_8992.jpg

One more update to come after I program, install and test the M72 Multi! :thumbsup:
 

kikaso

Grand Master
Joined
Jul 4, 2020
Messages
560
Reaction score
706
Location
Brooklyn
Nice job! What could have caused all of those bad chips?
 

ShootTheCore

Enlightened
Joined
Jan 20, 2016
Messages
1,842
Reaction score
2,831
Location
Logan UT
My assumption is that either the power supply got turned up way too high, the power supply failed catastrophically, or the JAMMA harness was plugged in upside down.
 

Neodogg

Enthusiast
Joined
Aug 17, 2015
Messages
164
Reaction score
128
Location
Cincinnati, OH
The KNA6034201 reproductions from @caius arrived and FINALLY the board set is working 100% with no jailbars!

IMG_8988.jpgIMG_8991.jpgIMG_8990.jpgIMG_8989.jpg

I ran the board for 24 hours as a "soak test" just to make sure that everything was solid. For good measure, I tried swapping in each of the original KN customs one at a time just to see if one of them was good, but unfortunately both custom chips have issues.

In the end, I ended up replacing 14 failed chips across both the middle and bottom boards.
IMG_8992.jpg

One more update to come after I program, install and test the M72 Multi! :thumbsup:
Fantastic work!
 

kuze

Champion
Joined
Jul 22, 2015
Messages
1,884
Reaction score
1,298
Location
DFW
Very nice work, props to you for sticking it through to the end. I know it can get pretty disheartening once you’ve replaced so many chips! Thanks for sharing the journey through pics :thumbup:
 

Apocalypse

Staff member
Legendary
Joined
Dec 6, 2017
Messages
3,719
Reaction score
6,401
Location
New-Zealand

ShootTheCore

Enlightened
Joined
Jan 20, 2016
Messages
1,842
Reaction score
2,831
Location
Logan UT
Last update on this board!

I've replaced all the electrolytic capacitors and fitted the Apocalypse M72 Multi. Playing a round on each of the games now and everything is working 100%.

IMG_9022.jpgIMG_9026.jpgIMG_9027.jpgIMG_9031.jpgIMG_9034.jpg

I'm glad to have this project wrapped up! Time for it to go home to its owner. :D
 
Top