What's new

whatnot

Student
Joined
Oct 28, 2019
Messages
107
Reaction score
80
Location
USA
Hey there, past couple of days i've been running my head against the wall trying to figure out why I can't save the game on my Type-3 Chihiro after a netboot. I replaced the dead cells with 2 new cells and charged them externally until they were 4.2v each - normal voltage is 3.6v but Chihiro wont accept them being fully charged until the pack is at least 8.3v.

Probing around I have 3v near both dimm slots. Chihiro thinks it's fully charged as noted by the green light on the media board. I've tried with media firmware versions 1.15 and hacked 4.00, tried with "real" PIC and encrypted game. Tried with both the original Samsung RAM and some replacements I have around the house.

You turn it on it goes initing media board, "Testing a game program" very quickly, then to checking network.
With triforcetools I dumped the DIMM memory and the game is there.

I'm not sure what else I could try.
 

Attachments

  • PXL_20210409_032004373.jpg
    PXL_20210409_032004373.jpg
    160.3 KB · Views: 52
  • PXL_20210409_081722985.jpg
    PXL_20210409_081722985.jpg
    160.2 KB · Views: 53
  • PXL_20210409_075810650.jpg
    PXL_20210409_075810650.jpg
    160.9 KB · Views: 56
Last edited:
If you hold your dimm with the battery right under, you should find capacitor CT8 on the right side of your sdram modules.
I measure 3V on that capacitor when the dimm is powered by the battery. Maybe you could do that check on your dimm as well
If you don't have that voltage, your sdram isn't powered so it's normal it looses it's game.
 
maybe the protection board on the battery is the issue.
if you run the console - do you see it trying to charge the cells?
 
He seems to have over 8 Volt coming out of the battery pack. It's scary if they would be connected without a bms board. If the system relies on the BMS to stop charging the batteries when they are full, they might overcharge without such a board. There is also the issue that they shouldn't be discharged under 3V / cell. If the temperature resistor is missing, a good design might simply ignore the battery and won't attempt to charge / discharge it.
 
Chihiro will charge until ~8.3V measured on the pack, at which point the green light you can see through the metal turns on. I had 2 different packs one with 2 red wires and a black and one with red blue and black. I setup 2 different packs using the charge controller from both of them and wired exactly the same way. Both of my mediaboards act the same way, and I recapped one of them as a test as well.

Privately obcd asked me to check for 3v around the RAM module and I can confirm there is 3v present in a lot of places when the machine is off and the batteries are attached.

I dumped part of the DIMM using triforcetools and confirmed the CRC is present as well as what appears to be correct data.
 

Attachments

  • PXL_20210407_174202235.NIGHT.jpg
    PXL_20210407_174202235.NIGHT.jpg
    193.7 KB · Views: 38
  • PXL_20210409_032004373.jpg
    PXL_20210409_032004373.jpg
    160.3 KB · Views: 43
  • PXL_20210410_025032424.jpg
    PXL_20210410_025032424.jpg
    146.3 KB · Views: 47
  • PXL_20210424_011438355.jpg
    PXL_20210424_011438355.jpg
    179.1 KB · Views: 42
Last edited:
Decided to get the DC2DC @Mrhide suggested, set to 7.2v and it's still doing the "Testing a game program" for a second then right back to checking network. The DC supply is a 12v 500mA.

From the time I last posted I decided to do a hacked retail to Chihiro using the files on AP (which worked great) in an attempt to see if something about the Xbox board was causing it. The only thing left to replace now is the mediaboard (but this would be the 3rd if I replaced it), although I'm not sure why I'd have 2 boards with the same issue, one of them being fully recapped.. I've also burned a new PIC using known working hex.

The 2 mediaboards I have, one is running the hacked 2.19 bootrom, and the other is running an older 2.11. I've tried combination of baseboard, mediaboard, filterboard (01-91 vs. 02). Noting that 1 set has a wire and is a newer revision and the older does not have the wire. The RAM is the stock Samsung, and I also have tried a generic A-Tech dimm. I've tried 2 different network boards, 1 being completely recapped.

Really not sure what else.
 
Picked up another mediaboard, still having the same problem. The only thing I haven't completely replaced is the PIC. I have 2, one eBay one, and one I burnt myself (using my own compiled version and someone's known working version). Surely this wouldn't be an issue that it's actually connected to the open internet vs. a LAN only?

I'll probably give up hoping to get the game to actually save to the board.
 
thinking on this, did you try different ram?
is the dimm bios hacked?
i remember someone was trying to patch a bios to skip some tests to speed up the boot.
 
I have 2 different sets of RAM, one that came original (Samsung), and one set I had laying around (A-Tech, 'new' made from old stock). Both sets of RAM test fine running memtest86 on a older computer I have for multiple runs, and tests fine in segaboot's test.

As far as the firmware - we're now on 3 different revisions of it, one is running the hacked AP firmware to boot CF (haven't tried this as I care more about saving), one that I've completely recapped running 2.11, and this new one running 2.15.
 
Coming back to this.

Since my last post i've tried 3 more sticks of RAM, including a CL2 in case the speed was a problem, more PIC bins including ones I compiled myself and others you can find on the forums, recapped half of the Xbox board (caps that are generally problematic), and a couple of caps on the base board.

There are 2 different revisions of the base board and media board (one with the bodge wire and one without), I own both types and have tried combinations of the two. There are also 2 different versions of the filterboard, and i've tried changing that as well.

The games are direct mame decrypts. Transferred using triforcetools, transfergame, transe. I've tried it where it is able to talk to WAN, where it's only on a LAN only connection. Tried with DHCP and Static IPs.

I still cannot save the game on the DIMM, again the problem is it does "Testing a game program" for a second then goes to waiting on network. If you use tools to read the CRC from the DIMM it's correct for the game meaning if you use transfergame/transe you actually have to force the transfer to get the game on there again because it only checks the CRC.

Does anyone else have any thing else I can try? It would be really helpful for something I'm trying to develop to keep the game on the board... :/
 
Last edited:
maybe it only works for games loaded from disc or cf
 
Because you had me doubting myself I went ahead and checked with a reliable source, and indeed they do save on DIMM even via netboot.
 
And another update. I've moved to CF as I needed an easy way to reboot after sending WMMT (it changes the default net settings).

Even with CF it *still* doesn't save it on the DIMM with battery & DC2DC.
 
i suppose the voltage regulator circuit between the battery and the dram/refresh curcuits must be faulty.
i'v never seen that before!
 
Back
Top