What's new

Mitsurugi-w

Arcade Admini-Moderator
Staff member
Legendary
Joined
Jun 12, 2015
Messages
6,786
Reaction score
6,519
Location
New Bern, NC USA
It would be very strange for no game to boot at all. Can you go through the entire list and see if any boot? Gfx or sound issues are more likely.
 

sammargh

Professional
Joined
Jul 24, 2017
Messages
539
Reaction score
382
Location
South Dakota
This thing is cursed... So I stepped through every game and on my initial findings Bay Route and Wonderboy III both would boot to corrupt graphics. Wrestle War made a sound but black screen. Went back to test those three again once I had finished all the dip configurations to find they all three are now just black screens.
 

Mitsurugi-w

Arcade Admini-Moderator
Staff member
Legendary
Joined
Jun 12, 2015
Messages
6,786
Reaction score
6,519
Location
New Bern, NC USA
If you want you can send it to me. If I can't figure it out I'll swap it.
 

Chron

Student
Joined
Jun 28, 2020
Messages
85
Reaction score
87
Location
Indiana
Pull your Z80 sound cpu and see if it starts. I started working on setting mine up last night and I’m having the same issues as sammargh. I programmed different eproms for 1-3 and still couldn’t get it to work. I tried reseating many times and just would have garbage on the screen or just would usually be a black screen.

I pulled the Z80A that I had purchased from eBay to replace the encrypted one on my altered beast board and the games start up just fine with out it! Weird! Gotta be bad then.
 

bodgit

Enthusiast
Joined
Sep 6, 2020
Messages
113
Reaction score
225
Location
UK
I think I've possibly got another borderline iffy EPROM. If I leave Golden Axe running in attract mode, it will eventually hang on a black screen.

Which EPROM should I look at? What other games are on the same chip, just to see if they have any problems?
@Mitsurugi-w any idea which EPROMs to start swapping out?

I've asked before, a basic document/post documenting how the games are spread across the EPROMs would be helpful to people as a starting point for troubleshooting.
 

duffcon

Professional
Joined
Feb 5, 2018
Messages
250
Reaction score
208
Location
Concord, CA
If they are crashing I would suspect roms 1, 2, and 3. Those three control program.

I'll ask about trying to put a list together of what games are affected by which eproms.
Yes please, this would be very helpful for T/S. For the most part my multi has been very good (v1) aside from that one time I needed to re-seat ROM3
 

sammargh

Professional
Joined
Jul 24, 2017
Messages
539
Reaction score
382
Location
South Dakota
My Z80 should be fine, Shinobi (unencrypted version) works without issue so it's likely the board itself. Since you mentioned 1-3 as being PRG I did some real quick probing vs Shinobi and I think I see at least the major issue. OE appears to go from the roms to pin 15 CN4 A+B depending on odd and even. On 27c322 I see GvPP linked on all 3 chips however it does not go to either pin on the CN. I'm not really sure how the multi is supposed to terminate on the CNs so I suppose I'll be sending Misturugi a PM to ship this board off.
 
Top