What's new

HardAzRockz

Enthusiast
Joined
Jul 25, 2020
Messages
154
Reaction score
101
Location
Tucson, az
So I've been waiting for the release of the Sega System 18 Multi. I bought a Shadow dancer a while back. I've been trying to get it working correctly. I've scoured the internet looking for information but there really isn't much regarding the Sega 18. The screen displays duplicate text and images and have no sound. I replaced several eproms on the roms board with 27C2001 and it has made the image better but I still have graphical glitches and duplicate text, images and no sound. Any ideas where to look? Here are the 3 roms I haven't replaced yet. 20220128_100641.jpg
I looked for bad traces and found none. Neither the CPU or Z80 are encrypted. Here is a short video.
View: https://youtu.be/jZlAvin5s4E
 
Joined
Oct 2, 2021
Messages
31
Reaction score
37
Location
Germany
Looks like 64V isn't going to one of the background layers. How? Could be anything.
And it looks like one of the data lines of one (or more) of the graphics ROMs is missing (could be a bad ROM, bad socket, a bent pin or a bad BUS transceiver).
Without schematics, good luck...
I'd probably take a scope and look for signals that look like 64V, then short them to ground looking at the screen to verify they indeed are and then follow the trace, check if the chips it goes to are passing it along or if it gets lost.
Same with the lines through the title screen graphics - short graphics ROM data lines to ground and see if lines appear. If you find a ROM where no lines appear when you short one data pin, but lines appear on any other, congrats, you found the bad line. If you don't have a scope, short it to 5V. If the lines "invert", it's the ROM itself, if nothing happens, it's a BUS transceiver/latch/whatever down the line, but at least you've located the fault now.
 

HardAzRockz

Enthusiast
Joined
Jul 25, 2020
Messages
154
Reaction score
101
Location
Tucson, az
Thanks for the help. I've replaced every rom. I will check what you suggested.
 
Top