What's new

buffi

Grand Master
Joined
Aug 12, 2019
Messages
514
Reaction score
673
Location
Sweden
Hi! I have a Niko multi'd Type X2 that used to boot games fine. Haven't used it for a long time though, and whenever I try to boot games now, the machine freezes completely a few seconds after gamestart, and then just stays stuck displaying the same frame forever.

Any idea on where to start troubleshooting this?
 

KaPH33n

Grand Master
Joined
Sep 30, 2018
Messages
725
Reaction score
731
Location
CA
is it always the exact same frame? could be a hdd failure? is it a spinning disk or an ssd?
 

buffi

Grand Master
Joined
Aug 12, 2019
Messages
514
Reaction score
673
Location
Sweden
is it always the exact same frame? could be a hdd failure? is it a spinning disk or an ssd?
It's always at the same spot afaik, but it happens in different games.

Game loads for a few seconds, then freezes. Same spot each time.

Could be the drive (it's an SSD by Kingston)
 

Niko

Champion
Joined
Sep 22, 2015
Messages
974
Reaction score
1,426
Location
Louisville, Kentucky
I'd try replacing the following in this order.

1.) SSD/HDD
2.) RAM
3.) GPU
 

buffi

Grand Master
Joined
Aug 12, 2019
Messages
514
Reaction score
673
Location
Sweden
Tried swapping the SSD and that didnt help. Both were kingston though so ill try swapping in a 250gb hdd i have around.
Have ordered some cheap ram ill try swapping next i guess
 

buffi

Grand Master
Joined
Aug 12, 2019
Messages
514
Reaction score
673
Location
Sweden
Got the new RAM and works perfect now so yeah, that was definitely it. Thanks!
 
Top