What's new

corpsicle

Beginner
Joined
Nov 7, 2020
Messages
7
Reaction score
2
Location
Sweden
Anyone have any idea why that would be? System seems to run fine, the psu gets quite hot though (not burning hot).
 

Niko

Champion
Joined
Sep 22, 2015
Messages
975
Reaction score
1,429
Location
Louisville, Kentucky
Fans are probably dead. you can find replacements online but you'll need to wire up the connectors.
 

corpsicle

Beginner
Joined
Nov 7, 2020
Messages
7
Reaction score
2
Location
Sweden
Is this a thing that happen on these? That both fans just die?
 

Niko

Champion
Joined
Sep 22, 2015
Messages
975
Reaction score
1,429
Location
Louisville, Kentucky
Is this a thing that happen on these? That both fans just die?
They can, I've seen them die before.

If the PSU is working, then it would be very unlikely for it to be anything else. Regardless you'd need to open the PSU to find out. Just be careful as PSUs are dangerous.
 

corpsicle

Beginner
Joined
Nov 7, 2020
Messages
7
Reaction score
2
Location
Sweden
ill be careful! Ive recapped a CRT recently and learned a thing or two about caution around electronics. :D
Need to get some new fans. Any idea if it needs to be those "square" ones or if i can buy a more common one and leave a gap?
 

Niko

Champion
Joined
Sep 22, 2015
Messages
975
Reaction score
1,429
Location
Louisville, Kentucky
You can just retro fit a more common size.
 

corpsicle

Beginner
Joined
Nov 7, 2020
Messages
7
Reaction score
2
Location
Sweden
Hrmp. Went in and poked around, moved the wires about a bit, unplugged/replugged the fan connectors, now they spin. Oh well, cheap and quick fix at least ^^
 
Top