Initial D Stage 6 AA Card Reader

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Only the -SG ones are designed for work with Initial D games.
      The -SGT models are for Thin cards and works on Star Horse 2 and Derby Owners Clubmachines.
      The -SGT models can work on some Initial D games, like ID5, ID6 and ID7, but testing of printer will not work properly on the game test menu.

      Thermal Head is differnt model and firmware on the board is different on both readers.

      Printer test will always fail on -SGT models.

      There is one important thing to do first:

      The Stocker on the card reader on the -SGT models is adjusted for feed cards of 0.30mm instead of the standard 0.70mm cards.

      There is a metal part between the reader and the stocker, with 2 allien screws that can be adjusted in order to let the reader to feed cards from the stocker with a width of 0.70mm.

      The gap must be adjusted using a normal 0.70mm card.
    • Works in ID6 and ID7 on game, on preprinted cards, sometimes when it needs to print a new card it fails, but not always, is something related to the printing firmware, but RFID R/W works.
      Also the PSU need to deliver 24V, with at least 4A, because on printing it needs a lot of current, same when erasing printed cards.
    • Hi,

      Thanks for the replies guys.

      Mine is the SGT model as well, but the seller sent me a different one to the auction listing. It was clearly not the same as the pictures in the eBay auction, the serial numbers were different for a start and mine had a rubber band missing off a roller at the infeed and one of the white rollers by the motor had dirt build up on it.

      It was obviously used and not NOS as he had mentioned in the auction. I could only really test the reader once my ID8 cards had arrived and I had the correct connectors. Although I'm cheesed off, at least the seller refunded the cost of the unit which is something I suppose.

      That's the serial pinout I've tried. I've just bought a DB9 Terminal block so will try making my own cable and try again.
      I'm probably clutching at straws at this point though.

      I bought the Initial D8 motherboard off Yahoo with the game already installed which is at v1.2 +D.
      The RingEdge jumper pack is set to 3+6+7 to ON. Does anyone know if this is this correct?

      The first thing I adjusted was the stocker, the card passes through that fine now.
      I checked all the cables were plugged in correctly and made sure the sensors are clear.

      In the service menu the card reader is not even seen, so I can't run any tests on it.
      I'm really stumped to what can be the problem, I've dismantled the unit and checked the control board for burnt chips etc but there's nothing obvious.

      I don't care about the errors on the reader as long as I can play the game.
      I've dumped a lot of cash into this project and this is the only thing holding me back from enjoying the story mode in the game.

      Thanks guys.
    • I wasn't going to take my refund and leave it be, but after seeing overwhelming response to people's experiences with this seller, I decided to act. I left negative feedback and reported the listing, if you feel like doing something about it, I recommend the same. I don't normally stir the pot, but the seller knows what he's doing, he can't possibly not after so many refund requests; he can't be getting anything out of it but keeps doing it anyway
      Be attitude for gains . . .

      1 : Be praying
      2 : Be praying
      3 : Be praying
    • The listing is for sure misleading, and I'm pretty sure mine is not NOS, either. The rollers are dirty. The sellers location is listed as Canada and he sends from HK (package from HK requires a signature in US, where I don't think it does from Canada). The unit is for sure not meant for ID as listed. There is reason to be wary if deciding to purchase.

      I was refunded purchase amount and allowed to keep it, so I got the unit for about $80 total, which is worth it to me for experimental purposes. I did get my unit communicating with my Lindbergh and my laptop, though, so I would feel differently had it not worked at all. My reason for requesting a return is that it's not an official reader for ID as advertised and that was my reason for purchasing. Given that the seller refunded and allowed me to keep it, he made amends in my book. He may be making a little money on the shipping price, but maybe not as I've had super expensive shipping on items off YAJ.

      After the post from @android, I tried the reader in game in ID5 and am happy to report it worked. The card image was printed as expected, even though printing fails in test mode. The test mode must be issuing a command that's not used in game.

      It's also worth noting that I got a blank card from ID4 to work for ID5. I think the cards might be region locked, though, so no blank US cards for JAP game. EXP ID4 didn't like my JAP ID4 card, at least in test mode - haven't tried in actual game yet. Note also that printed data won't line up
      on the wrong card as they're all a little different in layout and what gets marked where.

      Anyway - I'm in a good spot to get logs and see about emulating this reader for the games I have access to.
    • I am very glad to hear some progress on this process.

      If testers are ever needed for this process, I have Lindbergh Yellow with multi (Export ID4 and ID5 games) and an original Initial D Arcade Stage 5 Disc and Key I can run on my system.

      Random question here, I have the orange dual Card reader wired for Virtua Tennis 3. Is there any way to get this reader working for Initial D or is it a totally different card reader?
    • Ringo wrote:

      In the service menu the card reader is not even seen, so I can't run any tests on it.
      FYI: At least on the Lindbergh games the test menu is very forgiving to the point of allowing you to power cycle the reader when in the test mode. If it doesn't detect the reader, most of the options aren't selectable and it says something like no unit found. However, the test menu is sending constant polling commands and will pick right back up on allowing you to do tests once the reader is communicating. Ringedge users would have to confirm if ID8 behaves the same way, but that's the easiest way to check wiring and communication since you can power the unit down, swap wires, plug it back into the com port and power up to see if communication initiates.

      Hopefully someone confirms the Ringedge DIP switches for you.

      Edit: Also confirm that the DIPs on the unit are set per the pic post that @nismopunch made earlier. Several of the switches in the first bank impact the serial standard being used, and not having them correct would make it so that no communication can happen.

      I also don't recall reading if your unit shows any activity when powered. Even with no serial communication, it should cycle motors when being powered on. At least one of the DIPs in the 2nd bank impacts this. While I was experimenting with them, I had the unit in a state where nothing would move, even when power cycled.

      The post was edited 1 time, last by winteriscoming ().

    • Yes, my unit did have activity when powered on. The shutter would cycle and then stay in the open position. The motor and print head would also move. When I powered the reader up for the first time after adjusting the stocker eject slot height it took the card from the stocker and it would move to the grey rollers and just stay there. Only when I switched the jumper packs on and off did it then seem to function correctly.

      A little update.

      I completely dismantled the reader, reseated all connectors and unscrewed all sensors and tightened them so the screws don't bite so hard. I then redid the wiring to the serial connector following the pinout winteriscoming provided. I also turned on switch 3 on jumper pack 2 (the one with 4 switches) whilst powere on and the unit power cycled/reset itself. Like I said previously, some card readers use switch 3 to clear the nvram, whether this had any impact on my issue is anyones guess though.

      After doing the above I powered everything on and the card reader initialised and it's also now seen in the service menu. :)
      I can reset the unit and test a dispense from the stocker. I can confirm the Ringedge also gives a 'No Unit Found' message but I can't confirm if it will recover if the serial cable was unplugged before going into the service menu, when I get the DB9 terminal connector I'll try testing that. And also to confirm, the shutter stays open until the reader is initialised, then after it's initialised the shutter closes.

      But as has already been mentioned, the unit is not printing on my cards and I have to eject the card by pressing the view button + start button simultaneously when the error message is displayed. The main thing for me is that it does save the game so I'm now able to enjoy playing the story mode.

      Technically the card reader does work, but it's certainly not as advertised. I don't have any beef with the seller, but I can't categorically say whether he knew the readers didn't work correctly. I'm gonna give him the benefit of the doubt though as he was 100% polite with me and didn't question my integrity. If the card reader proves to be stable I'll probably send him a payment so I don't feel like I've hoodwinked the guy, it won't be the full 180 USD I paid but it will be a price I don't mind paying. I've bought off the guy before and I probably will again in the future.

      So thanks again for the input guys, it's always difficult getting info on stuff like this.

      Thanks. :thumbup:

      The post was edited 1 time, last by Ringo ().

    • winteriscoming wrote:

      Note to anyone else taking this risk, the seller says the item is located in Ontario, Canada, but ends up shipping from Hong Kong. Seller is ai.amusements. They keep posting new listings anytime one sells, so who knows how many they have.
      Just saw your post on this, I bought my ID2 Twin Cab from AI Amusements back in 2011. It was freight delivered from Ontario so they may have ties to a Hong Kong distributor but they have an actual location in Ontario. Not that it matters but they have legitimate cabs located up north.