A Freeware Taito TypeX Multigame

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Mitsurugi-w wrote:

      Ghostbusters did their job too well?
      :D It certainly seems that way.

      To follow up, I did get a game to boot every once in awhile last night, just for completeness' sake I did hook up another Sega I/O I had on had and it did the same thing. SO I'm kinda baffled as to what is going on here. I do wish I had another working Type X on hand to test. Also, anyone looking at the Type X mobos on ebay from Yaton? Don't bother, he's not testing them. My first one was DOA and the second one he sent me had a struggling PSU. Also three of my friends bought one and they were DOA too and they just got refunds. I got broken shit that I paid for. Buyer beware.
    • rtw wrote:

      That error has been haunting me.

      It seems to be slightly drive related.

      I am working on a fix but not a lot of time these days.
      OOOOOOHHHHHH, ok. Oh man, I thought I was having some serious issues. Thanks for making this by the way, when it does work I leave the game on for 3 or 4 hours anyway. ;D Also if this helps, the first drive I did was IDE and the second was sata. Both of them do boot from time to time, so it's good to know you can use either type of drives.
    • Today it was able to boot so while it was working I decided to reboot a couple of times. When I was on the multi menu if I counted to ten and then loaded a game ten out ten times it would boot.

      So to revisit this, I tried on several different machines and began to notice a pattern. If I let it boot on any machine I use it in, when the multi menu pops up, I count to 10 and without touching anything and any game I choose boots right up. Not sure if this helps anything just thought I would post it up. Tried about 20 different boots across 8 different machines.
    • kidpanda wrote:

      Today it was able to boot so while it was working I decided to reboot a couple of times. When I was on the multi menu if I counted to ten and then loaded a game ten out ten times it would boot.
      Thank you for the feedback, you have hilighted the core of the problem :D

      The original TypeX, X2 etc save configuration data to the D: disk. My original multi just placed all the files on the root of D with interesting results.

      When @Niko did his multi he used a different approach.

      Using the subst mechanism in Windows he created a "substed" D: drive, like this.

      Source Code

      1. C:\>subst D: c:\Raiden_III
      2. C:\>subst
      3. D:\: => C:\Raiden_III
      One important thing to note is that in order to do accomplish this we need to delete the D: drive.
      Since the TypeX employs UWF (Read-only filter) on drive C: the D: drive will automagically be recreated when the system is booted.

      So when booting up:UWF - Recreate drive D:
      Start menu from c:\TtxMulti

      The existing design uses a launch file which is written to drive D:

      When you select a game in the multi a file is written to drive D: containing the game to launch, but since the system is "recreating" drive D: the file does not really exist on the disk, this is why you get the: no entity error.

      There are other mechanisms we could use to select the game, pipe, drive c:\ but this method does not work with autoboot, autoboot must have a file written to a persistent disk.

      I tried to move the launch file to a small partition called F: which worked a lot better but the problem moved to the subst command instead.

      tl;dr

      I need a program snippet which will tell me when drive D: has been recreated properly.

      If anyone has a suggestion, I am all ears.

      My next thing to try is using GetDriveType() to determine if it returns: DRIVE_FIXED.

      And if not wait a bit and retry until it is done, or just wait 7 seconds after starting :D
      The future of ST-V rests upon our work and your work
    • atrfate wrote:

      Almost like the X line of arcade machines are pcs, and will run anything that was designed to run on windows

      It should also be capable of running my theme vertically, although id suspect performance would be awful on an ide channel socket 478 cpu
      So... Anyone game?

      I tried the drag 'n drop instructions under the TTX2 Multi thread, I can see 'Frontend' in the game list, but launching it brings me to a black screen...
      I guess there are appreciable differences between the TTX1 and TTX2 multi? @Niko

      I'm running 2GB RAM with a 3Ghz processor ready to drop in as well as a Sata SSD... hopefully that will improve performance...