What's new

xodaraP

Enlightened
Joined
Sep 21, 2016
Messages
4,413
Reaction score
3,039
Location
Gold Coast, Australia
Hi everyone,
I recently fixed a CPS3 motherboard that was failing a write at 6m24s remaining. It was reading the CD drive no problems but failed at that point every time.

I have since repaired the fault (bad trace going to CCU custom) and booted the cart, loaded 2I and confirmed it was fixed.

Since loading 2I, I now cannot get the system to load another game, it will not read the CD ROM or SCSI2SD. My CD drive failed last night so I'm now just using SCSI2SD. It will mostly read the disc as 2I and ask if I want to load it, and will load it, but if I enter the SuperBIOS and try to load any other game, it tells me the CD ROM is not properly connected or that the disc is invalid.

Using latest SuperBIOS, works fine on 2 other motherboards.

I have so far checked:

- All traces from SCSI connector are working correctly
- Multiple drives
- Multiple cables
- 12v is running 11.95v under load
- Haven't tried another cart yet because my spare needs to be modded (which I have done but it isn't booting for some reason, am working on fixing this)

Has anyone run into a similar issue?
 

Derick2k

Immortal
Joined
Nov 14, 2015
Messages
8,114
Reaction score
6,514
Location
NYC, USA
Try swapping out the simms for another set of know working ones is all can I think of trying and see how it goes. Check that the scsi2sd works with another MB. Process of elimination to help narrow down the fault.
 

xodaraP

Enlightened
Joined
Sep 21, 2016
Messages
4,413
Reaction score
3,039
Location
Gold Coast, Australia
Found the problem. Busted via going to the GLL custom. Jumpered it and it's loading via SCSI2SD now
 

xodaraP

Enlightened
Joined
Sep 21, 2016
Messages
4,413
Reaction score
3,039
Location
Gold Coast, Australia
Not sure, it just died one day and I never worried about trying to fix it because I assumed it wasn't really possible.

There was an area with 2 or 3 corroded looking traces, turned out 2 of them definitely were and the vias were trashed. It's now just loaded 3S and is running nicely.

It's getting loaned out for a while and will be kept as a spare :)
 
Top