What's new

tronbaby

Student
Joined
Jun 10, 2018
Messages
59
Reaction score
9
Location
Manchester UK
Hi all,

I've got a Lindbergh Universal cab and when I play a Lindbergh multi using the proper power connectors, the Sega Type 3 IO board powers up and works just fine.
I've tried different JVS systems - RingEdge 2, TTX2, but when I connect the USB JVS cable, they give a 'no IO error' as I can see the IO board is no longer receiving power.
Ideally I want to keep the RingEdge 2 in there.
First question - what power adaptor would I need for the standard Lindbergh PSU to run the RingEdge?
Secondly, any idea why the IO isnt getting power when I try a different system?

Thanks
 

Arthrimus

Grand Master
Joined
May 18, 2018
Messages
423
Reaction score
1,276
Location
Arkansas
Are you disconnecting the stock lindbergh PSU when you switch systems? The stock PSU provides cabinet power in addition to powering the PCB so if you disconnect it your I/O board will no longer receive power.
 

tronbaby

Student
Joined
Jun 10, 2018
Messages
59
Reaction score
9
Location
Manchester UK
When I switch systems I’m powering the other systems separately, not through the Lindbergh PSU, as I don’t have an adaptor to power them through it. But I’m leaving that connected and not touching anything else, as I know that powers the rest of the cab.
As I’m writing this, I’m guessing that’s the problem, does one of the 2 power connections that I plug into the Lindbergh mobo also provide power out to the IO?
 

tronbaby

Student
Joined
Jun 10, 2018
Messages
59
Reaction score
9
Location
Manchester UK
Quick update. I just need the 24pin power connected to the Lindbergh mobo (CN1) for the whole system to work correctly.
Without using that power connector to the mobo, the IO doesn’t get power.
Which seems strange, I didn’t think the 2 were connected, seeing as all other cab features power up fine without it.
How has anyone else with a Lindy got a different system powered up and working? Feels like I might need to use the Lindy PSU to power a different system?
 

Arthrimus

Grand Master
Joined
May 18, 2018
Messages
423
Reaction score
1,276
Location
Arkansas
The Lindbergh power supply has 2 modes, JVS and ATX. There is a switch on the power supply that controls this. If the switch is set to ATX mode it will not power on when it is not connected to your Lindbergh motherboard. If you switch it to JVS mode it will always power on even when disconnected from your Lindbergh.
 
  • Like
Reactions: nem

tronbaby

Student
Joined
Jun 10, 2018
Messages
59
Reaction score
9
Location
Manchester UK
Great, I didn’t know that, thanks Arthrimus!!
 
Top