What's new
I angle and place the metal tabs into the holes of the PCB and solder them directly in.
@Frank_fjs @Arthrimus lol I think I have found my PCB nemesis!

Brand new board, new components, programmed first time (E2 low fuse), able to "Read All"

Nothing when I plug it into the minigun on a konami game with konami adapter, tried port 1 and 2, did a bunch of continuity checks from the game edge

Went through remapping mode, no buttons work, start doesn't start...

Must you remove J1 after programming for it to work?

Update, I removed J1 and it made no difference.
Last edited:
I have no clue what the problem is. I have a couple of the same PCB revision that you are using floating around the workshop and I have programmed the newest firmware on them with absolutely no issues.
Thanks @Arthrimus I just tried my CPS2, the controller does nothing, it looks like from your video the up/down/left/right should work even before remapping.

All I did was use eXtreme Burner with saturn_controller_demux_remap_autofire.ino.standard.hex, write Low Fuse E2 which was successful.

I must be missing something, I have two retrobit wired controllers, I made two PCB's, I have tried multiple game boards, nothing.

I'm not setting any other fuses, am I supposed to?

I'm not using the Arduino IDE for anything, am I supposed to?
Last edited:
Yes, the d-pad and start should work without entering button remapping mode. Have you tried cleaning the pins of your controller plugs and the Saturn ports that you are using for the adapters. The ports on those extension cables don't grip the controller plug very tightly so the pins need to be really clean to get a good connection.
Honestly I have no idea what's going on, can someone in Oz sell me a known good one?

I'm starting to think it's either a mistake in the PCB production or an issue with my USBAsp, I'm stumped.
@Frank_fjs do you have any stock of this still? If so, let me know, I probably have to send @K0NAM1 some stuff soon-ish and could just send him my Saturn adapter and buy another from you next package?
I'm dry man. Got 2 for myself and that's it. If you send me a couple of Saturn extension cables for me to harvest the connectors from I'll gladly sneak in a few PCBs in my next order.

Did you check your soldering regarding the Saturn connector for shorts? One pin inadvertently shorted to ground is all it takes to prevent it from working.
Thanks @djsheep & @Frank_fjs

I have 3 spare saturn cables, 9 spare PCB's, MCU's...

I did a continuity check on all the pins with the adjacent pin, to detect a bridge between pins. I just did a continuity check between every pin and ground (PIN 9).

I mean there ain't much to check on this PCB, 68 solder points, the programmer says it's programmed, connectors and controllers are brand new.

I could bust out the oscilloscope and poke around.

5v is getting to the SAT2NEO MCU, maybe I will use the hacked up extension cable to confirm 5v and continuity on the Saturn cable.
@Arthrimus & @Frank_fjs something strange, if I plug the Saturn controller cable in slightly, on the CPS2 test menu, the cursor cycles through the menu options like someone repeatedly pressing the down arrow...if I plug the cable in more then nothing.
These adapters somewhat fit, but they didn't work in the adapter PCB. Not sure if it was due to my bad bending of the pins (I checked for shorts before, though) since the pics programmed worked in my new setup. I did not test these adapters before with my Saturn.
Could you expand on this please, you had Saturn connectors that soldered OK, didn't have any shorts and they still didn't work?
The metal sheath of the female dsub, it's typically removed to allow it to insert into a male dsub.
@Frank_fjs, thanks, my female dsub has the metal sheath and fits into the minigun fine, I thought that the sheath might cause grounding issues and that's why it had to be removed.
It depends on the dsub(s) used, some won't mate properly with the metal shroud.

Another thing to try is to get hold of a regular Saturn controller and try the adapter with that.
I have a sneaky feeling the pins inside the Saturn connectors are not contacting well enough, I have continuity, if I wiggle my controller connector I can see the Konami test menu cursor move up on it's own, nothing I do can make the cursor move when I press a button.

I have cleaned them with IPA, I'm starting to think I might need to "hook" and lift those internal pins.
Another thing to try is to get hold of a regular Saturn controller and try the adapter with that.
Thanks, would a Virtua Stick be OK, there are quite a few of them around, Gamedude has them?
Maybe a Virtua Stick isn't a great idea, it looks like it has an MCU inside to do the auto-fire?


  • maybe not.jpg
    maybe not.jpg
    170.2 KB · Views: 168
There’s two models of the Virtua Stick, a grey plastic one with blue buttons (horrible) and a white one that has an Astro City vibe (great).