What's new

Suzuki_Bison

Student
Joined
May 30, 2019
Messages
40
Reaction score
32
Location
NY
The other day a friend of mine and I did a full cap kit on my MS8-29FSG in my astro. We found that after turning the monitor back on, the flyback became quite hot and gave off a lot of heat in a short amount of time.

We actually removed the metal casing on the chassis which enclosed the flyback, just to give the flyback a little more air. However, this doesn't really solve the issue of air flow within the cab and keeping the flyback cool.

I've been thinking of leaving the lower back panel of my astro cabinets off and purchasing a clip-on fan to flow air to the back of the chassis. Has anyone else experienced an issue of their flyback (on any monitor chassis) getting hot? Is this even normal? ?(
 

Rg111

Multi Boyz
Grand Master
Multi Boyz
Joined
Sep 30, 2018
Messages
699
Reaction score
654
Location
USA
Heat and electronics dont mix. I wouldn't leave a fan on it.

Are you certain the flyback itself is heating up? Did you discharge the monitor and touch it?

If that's the case, I'd replace the flyback.
 

rewrite

Multi Boyz Litigator
Legendary
Multi Boyz
Joined
Nov 9, 2015
Messages
6,537
Reaction score
4,359
Location
SoCal
You may also want to double-check your work. That's not really a normal thing to happen, and if it didn't do it before the recap but does now, you should have a fair idea what's causing it.
 

Suzuki_Bison

Student
Joined
May 30, 2019
Messages
40
Reaction score
32
Location
NY
Heat and electronics dont mix. I wouldn't leave a fan on it.

Are you certain the flyback itself is heating up? Did you discharge the monitor and touch it?

If that's the case, I'd replace the flyback.
To clarify what you were saying concerning heat and electronics not mixing, that's why I was thinking perhaps putting a fan on the edge of the cabinet shell (with air blowing onto the chassis) would be a smart fix. Though in terms of replacing the flyback, they don't make the flyback for the MS8-29FSG anymore.

Now that I have two Astros in my possession, looking to have an extra chassis or two is certainly a smart idea, though they seem to be quite rare, if even available at all. When we discharged the monitor, we didn't notice any heat or anything coming off of the flyback of course, but that's because it had been off for several minutes and we weren't really looking for it, I suppose.

After several minutes back on, we realized how it was giving off quite a large amount of heat and the metal plate which is on the chassis and surrounds the flyback was (seriously) almost warm enough to cook an egg.
 

Suzuki_Bison

Student
Joined
May 30, 2019
Messages
40
Reaction score
32
Location
NY
You may also want to double-check your work. That's not really a normal thing to happen, and if it didn't do it before the recap but does now, you should have a fair idea what's causing it.
Our original reasoning for performing the cap-kit was due to a high-pitched frequency which was coming from the monitor. We were'nt sure what specifically was causing it, and the frequency only seemed to occur once every so often, but when it did, it was loud and quite annoying.

One of the caps was about to go bad, and just last week I was experiencing a dim picture with the monitor which I hadn't had happen before. So, there were plenty of reasons to perform the cap kit. Our findings were that after performing the cap kit, the monitor dim picture issue was gone, however the ringing still seemed to happen occasionally.

We then realized it was coming from the flyback. Whenever the flyback adjustment pots were touched while it was on, it would give off the ringing. We are guessing (based on what others have said) that it's a coil inside the flyback, that has gone bad and is ringing when the flyback is heating up and reverberating.

Of course there is a chance of error, though I'm not sure this is common with the MS8-29FSG. I have heard certain spots on the chassis can become quite crispy. ?(
 

rewrite

Multi Boyz Litigator
Legendary
Multi Boyz
Joined
Nov 9, 2015
Messages
6,537
Reaction score
4,359
Location
SoCal
I wasn't questioning your need to do the cap kit, I was suggesting you check your soldering work and cap directions. If it wasn't heating up before the cap kit, but does now, it would point toward something you've done, y'know?

As for the new info with the ringing/etc, you can always try tightening it to the board a bit more if it has mounting screws, or as most people do, epoxying the flyback in place. Won't solve your problems, but you may get more time out of it without the headache (literally).
 

Suzuki_Bison

Student
Joined
May 30, 2019
Messages
40
Reaction score
32
Location
NY
I wasn't questioning your need to do the cap kit, I was suggesting you check your soldering work and cap directions. If it wasn't heating up before the cap kit, but does now, it would point toward something you've done, y'know?

As for the new info with the ringing/etc, you can always try tightening it to the board a bit more if it has mounting screws, or as most people do, epoxying the flyback in place. Won't solve your problems, but you may get more time out of it without the headache (literally).
In terms of epoxy, would you recommend a certain brand? And is it a good idea to epoxy the pots in place? Or do you mean the flyback to the chassis itself?

We did experience a few traces on the chasis which seemed to lift with the heat of the solder from various caps being replaced and then had to be reset. I guess my next step of action (aside from possible epoxy) would be to see if my other cabinet is having the same type of behavior. But so all n all, it's basically uncommon for a flyback to be generating any type of heat?
 

Suzuki_Bison

Student
Joined
May 30, 2019
Messages
40
Reaction score
32
Location
NY
Ohh I see. I didn't know that. The other day my monitor wasn't turning on at all so I'm sending the chassis away to be looked at. Too many odd/random issues.
 
Top