What's new

Chadmon10

Beginner
Joined
Apr 28, 2022
Messages
4
Reaction score
2
Location
Denver, CO
I am new to crv monitors and have a wells gardner monitor that is experiencing some issues of blur, and a dark spot (or off color spot) in the upper right quadrant. I’m not sure what is the cause, and am fairly good at fixing things so if anyone could take a look and give me some advice that would be greatly appreciated!

View: https://youtu.be/Pzd5_CSP2Jw
 

Chadmon10

Beginner
Joined
Apr 28, 2022
Messages
4
Reaction score
2
Location
Denver, CO
I also want to add that when I first got this a year or so ago, the picture wouldn’t always come on. I’d have to turn it on/off a few times. But since then it’s been pretty solid aside from the blur.
 

kingau

Professional
Joined
Jul 22, 2015
Messages
307
Reaction score
168
Location
nyc
That black wire it your degauss wire, looks like you need to replace your caps.
do you have a degauss button on your machine?
 

Chadmon10

Beginner
Joined
Apr 28, 2022
Messages
4
Reaction score
2
Location
Denver, CO
That black wire it your degauss wire, looks like you need to replace your caps.
do you have a degauss button on your machine?

Where would I look for something like that at? Is that a literal button?

I just grabbed a flashlight and looked around but didn’t see any buttons. :(
 

Chadmon10

Beginner
Joined
Apr 28, 2022
Messages
4
Reaction score
2
Location
Denver, CO
Here's a link of Mike repair vlog... lots of great tips and info!
Thank you!!!

I will be watching this video here in the next hour. I have boat loads of capacitors on hand so hopefully will be able to complete the recap in the next day or so.

I will for sure post back here with the results.

Also I have a lethal enforcers jamma being delivered today and hopefully it has some test patterns I can use. I’ll also need to reverse (mirror) my image by flipping yokes? (Not sure if I am saying that right)

So this will be coming apart over the next day or so. 👍🏻🙂
 
Top