What's new

oneleaf86

Grand Master
Joined
Nov 14, 2016
Messages
605
Reaction score
942
Location
Melbourne, Australia
Can't manage to get white label to boot at all and instead I just get this error message. Black label boots and plays fine though.

EDIT: After rebooting the board a few times it seems to be working on my setup now. Unsure as to what was causing the errors, maybe some data stored in NVRAM?

From what I've played so far both versions seem to work 100% :) . Well done to all that contributed to getting this working!
 

Attachments

  • error.jpg
    error.jpg
    75.2 KB · Views: 120
Last edited:

Apocalypse

Staff member
Legendary
Joined
Dec 6, 2017
Messages
3,526
Reaction score
5,970
Location
New-Zealand
Awesome work @Asure.
Thanks a lot.
However I can't download it, hosting site is instantly detected as harmful by my antivirus with some very nasty stuff. Can it be hosted to a safer place please?
 

XeD

Grand Master
Joined
Jul 6, 2016
Messages
686
Reaction score
378
Location
Vancouver BC Canada
Can't manage to get white label to boot at all and instead I just get this error message. Black label boots and plays fine though.

EDIT: After rebooting the board a few times it seems to be working on my setup now. Unsure as to what was causing the errors, maybe some data stored in NVRAM?

From what I've played so far both versions seem to work 100% :) . Well done to all that contributed to getting this working!
I get the same error on my sheepnova cart using the KoVSH donor. Resetting it a few times did nothing for me. If I let it time out sometime it will pick the black version.
 

oneleaf86

Grand Master
Joined
Nov 14, 2016
Messages
605
Reaction score
942
Location
Melbourne, Australia
I also played with the dip switches a bit, try flipping dips 2-8 on and see if that effects anything. Otherwise I have no idea why mine suddenly started working.
 

Asure

Professional
Joined
Jul 24, 2015
Messages
398
Reaction score
423
Location
Netherlands
Do any of you have high scores? Is there a battery on your boards?
I have dip 8 on to save scores, and a battery is installed. No other dips set.

Also the score table is not 'default from factory' as ASU is in the score list, and it seems both games use the same score table for some reason, and save scores there as well.
Maybe it's the reason mine boots perfectly each time. You can see it in the video.

* I didn't hack the score table, i just meant to say on my mobo the game had written data to my mobo's NVRAM there which i have assume to be correct. So my nvram is on OK shape i think.*

The patch worked 100% on my PGM from the first time i booted with this eprom with no issues like you guys are seeing. I too have a Sheep Nova cart.

Note: It's not a super clean patch. I just nopped out the writes/reads to 0x500000 where the ASIC sits on the original cart, as well as the data manipulations and the CMP to the result, and it worked the first time and every boot after that. Maybe i need to revisit and see in more detail?

For now, try do do a boot w/o any cart and clean the nvram from the PGM bios first, and see what happens. (I did the same when my PGM mobo first arrived.)
 
Last edited:

Apocalypse

Staff member
Legendary
Joined
Dec 6, 2017
Messages
3,526
Reaction score
5,970
Location
New-Zealand
Also the score table is not 'default' as ASU is in the score list, and it seems both games use the same score table for some reason, and save scores there as well.
Whyyy? Now I have to fix that. ;)
I like hacks/patches to be as close as the OG as possible, I never hide my name or anything within the ROMs. I like minimalism with as little as possible modified.

Also funny enough @lorenzo2mars asked me if I could make a white and black version on the same cart, just like you did.
 

Asure

Professional
Joined
Jul 24, 2015
Messages
398
Reaction score
423
Location
Netherlands
I didn't hack the score list, i just meant that both games read the same place in nvram even if the board has different slots for games like MVS has.
I just played good enough that the game has me on #1 in the list, and there is a list written. I didn't tag the rom with my nickname :)

It's just meant as an example, that my mobo has some stuff stored in nvram for the game. Maybe the other users didn't clean nvram and set it to factory default from bios and in the game.

I can see in some videos from the AMB cart that the score table/nvram is screwed on them as it shows bad ship colors and wierd score entry data on first boot(s).
Same as happens in MAME on clean boot.

I know from experience that many PGM single board (Espgaluda comes to mind) will do wierd things when nvram is corrupt or not as expected by the game.
Espgaluda i got had random resets mid-game. However, everything was OK after i placed a new battery, and did a full factory default set from the bios.

DDP DOJ is basically a single board game running on a cart system and i guess it doesn't expect/like to be detached from its motherboard at all.
It is also known for some traps where it won't play black label if you remove the battery.

I hope nvram resetting and in-game resetting helps solve the issues others are having. Otherwise i have the issue where i don't know from which rom revision this AMB hack was made and how/why/what/where was patched. (I had assume he just disabled the menu to cash in on it later by charging for an update rom.)
 
Last edited:

Fluffy

Grand Master
Joined
Dec 15, 2018
Messages
506
Reaction score
908
Location
UK
Whyyy? Now I have to fix that. ;) I like hacks/patches to be as close as the OG as possible, I never hide my name or anything within the ROMs. I like minimalism with as little as possible modified.

Also funny enough @lorenzo2mars asked me if I could make a white and black version on the same cart, just like you did.
Please document anything you find regarding headers, bios calls or parameters!
 

XeD

Grand Master
Joined
Jul 6, 2016
Messages
686
Reaction score
378
Location
Vancouver BC Canada
I took the battery out and did a system rest. The white version only load sometime and when it does it's missing text. The high score table and in game. Black version seem to play fine. I will have to do some more testing when I get home from work tonight.

PS how do you clear the nvram?
 

oneleaf86

Grand Master
Joined
Nov 14, 2016
Messages
605
Reaction score
942
Location
Melbourne, Australia
To clear the NVRAM you need to press the brown toggle switch to the right of the JAMMA edge while the board is running.
 

XeD

Grand Master
Joined
Jul 6, 2016
Messages
686
Reaction score
378
Location
Vancouver BC Canada
To clear the NVRAM you need to press the brown toggle switch to the right of the JAMMA edge while the board is running.
Hmmm ok, I did that too this morning. Same result
 

yosai

Enthusiast
Joined
Sep 29, 2015
Messages
219
Reaction score
142
Location
London
To clear the NVRAM you need to press the brown toggle switch to the right of the JAMMA edge while the board is running.
From experience, at least with the Cave PCBs this wasn't necessarily the case. Most of the time it would leave spurious characters in the NVRAM.

I found the best way for Ketsui was to factory reset from the test menu and for DaiOuJou was to enter coins and press start during the country warning screen. I never experienced any issues with ESPGaluda.
 

XeD

Grand Master
Joined
Jul 6, 2016
Messages
686
Reaction score
378
Location
Vancouver BC Canada
On my setup if I boot the Black version 1st the do a reboot I can load the white version. Else I have to coin up at warning screen to load the game and get pass the error. The free play dipswitch does nothing. It register in the dipswitch test but not in game. for now I will have to tell people to coin up right away
 

Asure

Professional
Joined
Jul 24, 2015
Messages
398
Reaction score
423
Location
Netherlands
You either have obvious nvram damages
Or the game settings were never saver there in the first place.

Try this

Dip 8 on rest off.
Boot to black label.
Enter test mode by holding test button.
Set the game to free play in the menus.
Exit the menus and exit test mode.
(Game saves to nvram at this point)
Note this mode is not the BIOS test mode.
Selection menu pops up.
Boot to black label to confirm free play works.

From this point on you should be able to select white and black label with no problems.
 

yosai

Enthusiast
Joined
Sep 29, 2015
Messages
219
Reaction score
142
Location
London
On my setup if I boot the Black version 1st the do a reboot I can load the white version. Else I have to coin up at warning screen to load the game and get pass the error. The free play dipswitch does nothing. It register in the dipswitch test but not in game. for now I will have to tell people to coin up right away
Do you have a battery on the board?
 
Top