What's new

mathewbeall

Grand Master
Joined
Nov 6, 2017
Messages
812
Reaction score
414
Location
Mission Viejo, CA, USA
Hmmmm... I think something is very wrong... I did the update - and no sound, at all...

Now the cart won't even boot up. I am going to try and revert firmware and see if that works.
 

Seb34

Beginner
Joined
Nov 8, 2019
Messages
10
Reaction score
8
Location
France
Hi,

Same troubles like you => Rollback and it's ok ;)
 

beast1x5

Professional
Joined
Jun 17, 2016
Messages
759
Reaction score
454
Location
Brooklyn New York
Menu version is still showing oct 8 2019 , new fpga firmware flashed but im getting no sound...
 

beast1x5

Professional
Joined
Jun 17, 2016
Messages
759
Reaction score
454
Location
Brooklyn New York
forgot to mention.. tried changing the menu music track and got a z80 error
 

mathewbeall

Grand Master
Joined
Nov 6, 2017
Messages
812
Reaction score
414
Location
Mission Viejo, CA, USA
Somehow - I had my SCART switch go out - so once I fixed that, I did roll back, but still no audio.... Will keep troubleshooting.
 

mathewbeall

Grand Master
Joined
Nov 6, 2017
Messages
812
Reaction score
414
Location
Mission Viejo, CA, USA
I do not have any sound - at least coming out of the front 1/8 mini jack. I don't have any other cartridge to test with... I can try and dig up a regular composite cable and see if I have some coming out of that.
 

acidrain97

Beginner
Joined
Jul 9, 2019
Messages
21
Reaction score
7
Location
los angels
No Sound here either. Rolled back, No sound. Reflashed, No sound. I'm getting z80 errors as well. My terraonion cart works peachy. Why do I have a feeling the cart is fried??? a $500 down the crapper. Not Very Happy at the moment.
 
Last edited:

mathewbeall

Grand Master
Joined
Nov 6, 2017
Messages
812
Reaction score
414
Location
Mission Viejo, CA, USA
@Darksoft - I think for the "rollback" you need to also update with an earlier CPLD file. I was troubleshooting with you and you sent me 8-27-2019 version. I rolled back to the old firmware/menu and then switched to this CPLD, and sound came back.

let me know if you want me to post the CPLD file I have, or if you want to officially update the rollback firmware pack with it.
 

mathewbeall

Grand Master
Joined
Nov 6, 2017
Messages
812
Reaction score
414
Location
Mission Viejo, CA, USA
Did some more testing - the CPLD file in the newest firmware pack is what is causing the sound to die... I upgraded just the firmware and top file - no problem, but when I did the CPLD file, sound died.
 

acidrain97

Beginner
Joined
Jul 9, 2019
Messages
21
Reaction score
7
Location
los angels
the roll back firmware does not have a cpld. Do you have a copy of the previous firmware?
 

Darksoft

Staff member
Immortal
Joined
Jun 12, 2015
Messages
8,977
Reaction score
10,390
Location
Poland
The pack had the wrong CPLD file and it's what was causing the sound to dissapear. File with FW was updated in the same place.

@acidrain97 your cart is not fried and if it were, we'll help you fix it. This is not Terraonion. Just install the files I just updated and it should fix it.

@mathewbeall, @beast1x5, @Seb34
 

Seb34

Beginner
Joined
Nov 8, 2019
Messages
10
Reaction score
8
Location
France
The pack had the wrong CPLD file and it's what was causing the sound to dissapear. File with FW was updated in the same place.

@acidrain97 your cart is not fried and if it were, we'll help you fix it. This is not Terraonion. Just install the files I just updated and it should fix it.

@mathewbeall, @beast1x5, @Seb34
Yeah !

Great for me

Sound and double reset are fixed !

Thank you ;)
 

beast1x5

Professional
Joined
Jun 17, 2016
Messages
759
Reaction score
454
Location
Brooklyn New York
The pack had the wrong CPLD file and it's what was causing the sound to dissapear. File with FW was updated in the same place.

@acidrain97 your cart is not fried and if it were, we'll help you fix it. This is not Terraonion. Just install the files I just updated and it should fix it.

@mathewbeall, @beast1x5, @Seb34
Everything is working proper now!! Thanks @Darksoft

Hubba hubba , I'm in the pink!!!!

-Terry Bogard
 

acidrain97

Beginner
Joined
Jul 9, 2019
Messages
21
Reaction score
7
Location
los angels
The pack had the wrong CPLD file and it's what was causing the sound to dissapear. File with FW was updated in the same place.

@acidrain97 your cart is not fried and if it were, we'll help you fix it. This is not Terraonion. Just install the files I just updated and it should fix it.

@mathewbeall, @beast1x5, @Seb34
Good job.. Yep everything is working again. Turned it on and no random glitchy graphics or file system corruption. Always a treat to hear AXEL. F in its glorious fashion... Ran a few games no weird things yet.

I'm always paranoid about updating firmware in the event something will destroy my console. Probably been asked before but is it possible some day to get neo geo cd's running?

Also is it possible to run homebrew on your cart?

Other than that thank you for fixing things. We old people love our Neo Geo's.
 

acidrain97

Beginner
Joined
Jul 9, 2019
Messages
21
Reaction score
7
Location
los angels
The pack had the wrong CPLD file and it's what was causing the sound to dissapear. File with FW was updated in the same place.

@acidrain97 your cart is not fried and if it were, we'll help you fix it. This is not Terraonion. Just install the files I just updated and it should fix it.

@mathewbeall, @beast1x5, @Seb34
Everything is working proper now!! Thanks @Darksoft
Hubba hubba , I'm in the pink!!!!

-Terry Bogard
better than the stink... like i was last night. Happy now!
 

beast1x5

Professional
Joined
Jun 17, 2016
Messages
759
Reaction score
454
Location
Brooklyn New York
The pack had the wrong CPLD file and it's what was causing the sound to dissapear. File with FW was updated in the same place.

@acidrain97 your cart is not fried and if it were, we'll help you fix it. This is not Terraonion. Just install the files I just updated and it should fix it.

@mathewbeall, @beast1x5, @Seb34
Everything is working proper now!! Thanks @DarksoftHubba hubba , I'm in the pink!!!!

-Terry Bogard
better than the stink... like i was last night. Happy now!
im under the assumption you don't play fatal fury special... but okay!
 

Fargon

Beginner
Joined
Sep 17, 2016
Messages
68
Reaction score
9
Location
UK
I'm still having sound issues. Don't know if I did the update correctly
 

FakeNoose

Student
Joined
Dec 15, 2018
Messages
157
Reaction score
35
Location
USA
Im having trouble finding info on whether neo cd is supported? the forum search is not very specific.
 
Top