What's new

mathewbeall

Champion
Joined
Nov 6, 2017
Messages
1,418
Reaction score
999
Location
Mission Viejo, CA, USA
I will have to check this out! I haven't had any issues with Chunskin's and his build though - I am using the NFC reader.
 

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
Thought I'd help I don't know if we have these yet but found a good image here:
https://jjstuff.com/products/new-sega-naomi-club-kart-card-601-11051-01-x-100-cards
Screenshot 2022-04-18 162714.png
 

XeD

Grand Master
Joined
Jul 6, 2016
Messages
1,030
Reaction score
838
Location
Vancouver BC Canada
@winteriscoming can you make a edit to the 1st post about configuring the Naomi 2 for serial with the jumpers. Spent a day figuring/checking my wiring and cable combination. Turn out my Naomi2 did not have the serial enabled.
 
Last edited:

winteriscoming

Champion
Joined
Feb 16, 2016
Messages
1,440
Reaction score
1,180
Location
Indiana, US
@winteriscoming can you make a edit to the 1st post about configuring the Naomi 2 for serial with the jumpers. Spent a day figuring/checking my wiring and cable combination. Turn out my Naomi2 did not have the serial enabled.
I can. Do you have the details? I don't recall them off hand.
 

XeD

Grand Master
Joined
Jul 6, 2016
Messages
1,030
Reaction score
838
Location
Vancouver BC Canada
I can. Do you have the details? I don't recall them off hand.
Here is a clear photo of my setup.
20220424_002639.jpg


JP5 = 2-3 (close to filterboard)
JP8 = 1-3 (away from filterboard)
JP9 = 2-3 (away from filterboard)
JP10 = 2-3 (away from filterboard)
JP11 = 2-3 (away from filterboard)
JP12 = 2-3 (away from filterboard)
JP13 = 2-3 (away from filterboard
 

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
So on the triforce, it's not happy, I have a triforce type1 and I follwed the instructions just 3 pins Ground RXD and TXD and no go on Mario Cart 2, I have to try mario cart 1 but for some odd reason the trifoce doesn't always show up on the WiPi ... maybe another SD card issue :P
Am I missing a setting or dip like on the Naomi ?
I know this isn't the right connector but it's what I had on-hand and it "works" mechanically

20220428_1710541.jpgError.jpg
 

mathewbeall

Champion
Joined
Nov 6, 2017
Messages
1,418
Reaction score
999
Location
Mission Viejo, CA, USA
I *believe* with the triforce you also need RTS and CTS? I always suck at searching my old posts at AP - because I made some custom cables and ran into this.

*found it* - what game are you trying?

https://www.arcade-projects.com/thr...-d3-wmmt-mario-kart-f-zero-ax.814/post-296881

Try hooking all these up (from that thread). If you can't get it working I can take a look this weekend at what my cable is wired as.

Pin 3 [or 8] (GND) - Pin 5 (GND)
Pin 4 (TXD) - Pin 2 (RXD)
Pin 5 (RXD) - Pin 3 (TXD)
Pin 6 (RTS) - Pin 8 (CTS)
Pin 7 (CTS) - Pin 7 (RTS)



Matt
 
  • Like
Reactions: XeD

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
Looking at running Mario Cart 1&2 and F-Zero
I found an 8 Pin connector among my parts bin, and de-pinned the connector, and was able to move the pins over, added the two extra pins, and we'll see tomorrow if it works, thanks @mathewbeall !
 
Last edited:

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
Ok, that didn't work, still same error... it won't communicate through the Game Test or the Game Initialization.
@whatnot When you say bridging you mean merging the pins for RTS / CTS to one pin, which one?

Looking online about bridging RTS/CTS isn't that what this does?
Pin 6 (RTS) - Pin 8 (CTS)
Pin 7 (CTS) - Pin 7 (RTS)
 
Last edited:

chunksin

Professional
Joined
Jan 21, 2017
Messages
288
Reaction score
556
Location
Birmingham, UK
My Triforce connector and pinouts below if that helps:

3 - Ground - wired to pin 5 on serial
4 - TXD - wired to pin 2 on serial
5 - RXD - wired to pin 3 on serial
6 - RTS - wired to pin 8 on serial
7 - CTS - wired to pin 7 on serial

I think you can join pin 6 and 7 in the connector directly together

1651245357120.png
 

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
So in the first cable with 3 Wires I had the sides reversed... but looking at the picture and where pins reside on your connector, and where they are in the diagram, I figured it out, but it still doesn't want to work... I know the wire colors are different because of the cable manufacturers don't have a standard to adhere to, but I checked with a pin in the Triforce Connector and a wire in the Serial Port, to make sure I had continuety... and all pins read as per the example.
Screenshot 2022-04-29 094052.jpgScreenshot 2022-04-29 094111.jpg
 

chunksin

Professional
Joined
Jan 21, 2017
Messages
288
Reaction score
556
Location
Birmingham, UK
How are you running the scripts? are you using WiPi?

Edit: you mentioned you are, OK make sure you are on version 6.1.7 at least and set the card reader emulator mode to auto in the Options page before you send the game
 
Last edited:

whatnot

Student
Joined
Oct 28, 2019
Messages
83
Reaction score
56
Location
USA
Ok, that didn't work, still same error... it won't communicate through the Game Test or the Game Initialization.
@whatnot When you say bridging you mean merging the pins for RTS / CTS to one pin, which one?

Looking online about bridging RTS/CTS isn't that what this does?
Pin 6 (RTS) - Pin 8 (CTS)
Pin 7 (CTS) - Pin 7 (RTS)
Connect RTS/CTS together on the Triforce side and you probably shouldn't need to run a wire for them
 

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
Yeah because the battery works, I don't always upload the Wi-Pi, I was thinking if I go into setup and then manually go to the card page for Mario 2 it would work also, but I'm not sure how to manually fire the card reader, I have to go through the docs again... :)
 

DCrosby

Student
Joined
May 6, 2021
Messages
68
Reaction score
68
Location
Los Angles, Ca
Ok, that was supposed to work, by going to manual and then activating the card, but I was able to set it to manual but as to the "Docs/Manual" For Mario Cart and F-Zero you have to create an empty card, which then launches the emulator, and it started working... so yes reading the docs closely works wonders! :D

P.S. I wonder if this is something you can spin up when the WiPi Launches the same as auto-loading a particular game, or maybe I should just set it that way.
 

bobbydilley

Professional
Joined
Apr 29, 2018
Messages
514
Reaction score
516
Location
England
Connect RTS/CTS together on the Triforce side and you probably shouldn't need to run a wire for them
I can confirm that bridging RTS and CTS together works for F-Zero AX, Mario Kart & Initial D so far.
 

bobbydilley

Professional
Joined
Apr 29, 2018
Messages
514
Reaction score
516
Location
England
@AbolishedEnigma I'm trying to work out the RS422 communication, and I was wondering if you'd be able to do another dump for me when you get a spare moment?

https://www.arcade-projects.com/threads/naomi-rs422.21444/#post-327985

I've recorded the output from the RS422 on the Naomi using Derby Owners Club World Edition Rev D when it starts up. I was wondering if you could record the same output but from the RS232 side of your conversion board, and we can see if the protocol is transparent or if there are more complex things going on. Ideally if you could unplug the card reader, and just record what the Naomi is sending without giving it a response that would be ideal.

Thanks in advance for your help, but feel free to tell me that you've not got time etc.

My general plan for this is to attempt to allow the card emulator to connect straight to the Naomi without that conversion board, but with it running at 2Mbps it's looking worrying!
 
Top