What's new
I tried out this file for the English version of Puyo Puyo Fever and am getting a black screen also. Any ideas?

My Set-up:
Multi-Bios set to USA [fixed version]
Capcom I/O [or JVS I/O]
NetDimm 4.02 [512MB]
RaspberryPi PiforceTools

Did anyone ever manage to get Puyo Puyo Fever's English version to work?
I tried it again yesterday and am still getting a black screen when I try to load the English version, but that regular Japanese one works fine.

[Edit: The "puyo_pop_fever-[GDS-0034]" file found elsewhere on the net is the export version that's in English and it will netboot and load without issue.]
Last edited:
Thanks very much @MetalliC - read up on those two topics, and they explained everything I was missing!

For others if they are interested the issues were:

- I was reading the addresses the wrong way around, due to the endianness. When I was quoting 0x00000040 I really meant 0x40000000 and ditto for 0x00003000 I really meant 0x00300000.
- This made it easy to see that it's only the first 0x300000 of the first IC that is actually decrypted, and not the first 0x800000 as I thought. The fact there is an unencrypted header at this point should have been a good hint lol (this unencrypted section is clearly the test mode, that for some reason in this game sits unencrypted unlike the other m4 games I looked at which encrypt test mode as well).
- The 40 I was seeing was actually a flag (explained in the naomi source code linked by MetalliC) to tell the naomi to decrypt that section. Seeing as I decrypted the first sets of bytes myself using a brute forcer, this needs to be turned off so that the naomi loads it as plain text.

Now very happy with a working netbootable version of Manic Panic Ghosts!

Next task is to try and get hold of a real serial IO board for the game so that I can find out the protocol and try to HLE it so I can play the game!
This is good info. :D Sending a PM. hopefully you are willing to share the bin file with someone who can test it on a legit cab :D
Last edited:
I'm having a weird problem with HOTD3 on Chihiro. Its a type 3 netboot setup and everything works except for music. I have sound effects just no music.

Other games work and have music. Its just HOTD3 that does not. I even tested on a second Chihiro unit and had the same problem.

Anyone else experience this or have any suggestions?
That patch changes the byte at: 0x2102e from 0 to 1 anyone know what that does ?


Answering my own question, it's a patch to make a type 1 image work on a type 3 unit
Last edited:
It has to be 512MB, the original GDX-0001 image is only 512MB. There is no reason to use 1GB on the Chihiro.
For some strange reason the Chihiro requires a dedicated image for each memory configuration.
Yeah, mines 512mb. No need for 1gig
Can hook you up with the rest of the chihiro 512 games too
is there any benefit to running 1GB over 512? any games require it or worse off with the lower memory?

this was originally a 1GB unit with the sticker and everything. seems strange that Sega would add in an extra stick and not use it.
I don't know of any games which require 1GB. IIRC some later games had 2 images stored on the GD-ROM one for 512MB and one for 1GB,
Reconfiguring to a 512MB setup is working with music! I played through most of the game with no issues. Thanks!

(for anyone else who needs to do this, switch over JP5 on the media board to position 2-3, also not sure if it matters but I left the stick in that is furthest from the ports)
Last edited:
Hi, can I ask for somebody to make a netboot image for Initial D3 Cycraft or if it exists? I haven't seen that file anywhere.
Last edited:
Hi, can I ask for somebody to make a netboot image for Initial D3 Cycraft or if it exists? I haven't seen that file anywhere.
The game is dumped in mame as inidv3cy.zip - dm me and we can see about converting it, I think there are guides.
I'd be interested in helping if you'd be able to test out my emulator with this game - https://github.com/bobbydilley/cycraft-emulator
Do you have a real cycraft?
This is GD-ROM: GDS-0039B.
If you have a CF setup you can run the decrypted binary directly.