What's new

zerox_dogma

Enthusiast
Joined
Dec 18, 2019
Messages
210
Reaction score
53
Location
Florida
I need buy some infinikeys but are out stock.
Where I can buy 5 infinikey . I wrote undamned but never received answers.
Patience, sir :) Was that you that wrote looking also for CPS1 InfiniKey? If so, that is the reason for delay.
Paradise should re-stocking soon. I'm just waiting for payment before I ship out.
-ud
Excellent. Thanks
 

Sp33dFr34k

Grand Master
Joined
Nov 8, 2015
Messages
1,293
Reaction score
937
Location
The Netherlands
I thought I read somewhere that the resistor you can find attached to the pins of cn2 on some rev 3/4 boards was there to help with key programming.
Some Rev.3/4 have a pull-down resistor on the clock signal to lessen the chance of bogus bits getting written, but after loads of testing, I never found it necessary (for InfiniKey, at least). Konosuke's CPicS2 adds a series resistor to one of the programming signals, but I don't know which signal or if it would even help in this Asia board situation.-ud
So your advice would be to just leave the resistor off? Found one in a rev 4.



Edit: Nevermind, you call it out in your install video, so I'll take it off as well :)
 
Last edited:

friedpotatoz

Enthusiast
Joined
Jul 22, 2015
Messages
210
Reaction score
162
Location
Seattle, WA
Derick2k was nice enough to send me one for my SSF2X board, undamned's video was super easy to follow. Thanks again guys! I just ordered 6 more from paradise.
Infinikey.jpg
 

VectorGlow

Student
Joined
Nov 14, 2015
Messages
52
Reaction score
16
I'm having a problem with an Infinikey and a grey B board running Street Fighter Zero 2 (960227 ASIA)

I'll first say that I've installed a few Infinikeys over the past few months but this is the first one that's given me a problem.

The B board rev is 93646B-7

From checking progettoemma.net the MAME name for this code is SFZ2N - in the Infinikey Game Select file this refers to SZ2N

So I set the jumpers accordingly by bridging the required pads - (numbered from 7 to 0) - 1010110

I then removed the battery from the B board - I should say that before I removed the battery the game was working just fine.


After removing the battery I shorted the three pins for EXC1 as I always do.



I then installed the Infinikey to the rear of the board (CN9, orientation was correct, etc), plugged in the B board and got a slightly out of sync blank display. I re-checked the Infinikey instructions and realised that I had forgotten to jumper the pad for 'open for 93646B-5' - so I jumpered that. Powered on again - the sync was then stable but still a black screen.

Checked everything again a few times and am now stumped.

Any ideas please what could be wrong? I've had a long day and am a bit tired so maybe I've missed something obvious.



EDIT: Forget all of the above, it was my mistake. As noted, I obtained the version of the game by looking at progettoemma.net - this stated that the MAME name was SFZ2N. That's wrong as I discovered when running ROMIdent on a dump of program EPROM 3 - the ROMIdent name is SFZ2A. Once I set the jumpers for that on the Infinikey the board booted just fine.

My apologies. Did I say I was tired? :)
 
Last edited:

Dk310

Enthusiast
Joined
Feb 13, 2017
Messages
214
Reaction score
109
Location
El Segundo, CA
I tried contacting undamned, he hasn't gotten back to me. (I'm sure he is busy) I want to buy 10 of these if possible.
 

Rotanibor

Enthusiast
Joined
Dec 11, 2016
Messages
111
Reaction score
145
Location
SoCal
@undamned
So, I'm trying to remove an InfiniKey (Mobo Rev.7 install) for a Darksoft CPS2 install, but try as I might I straight up can't remove the thing. How far do I have to go to fully disable the InfiniKey so a Darksoft CPS2 install will work? I would like to remove as few components as possible from it in case it gets reused on this board in the future.

Edit: I worked it out and got it removed. Went about it wrong from the start. I should have kept adding solder and turn it into one big molten mess instead of trying to remove the solder.
 
Last edited:

LWK

Student
Joined
Apr 22, 2020
Messages
43
Reaction score
14
Location
California
Have a weird issue with a X-Men Cota. I installed infinikey's in other boards and they work fine. This particular board though is a mess. It'll work, then green screen when I power it. I removed EXC1 & EXC5 completely. I took off the electrolytic cap and then soldered it back in.
This particular Infinikey I soldered to much with and set aside, I have a better soldering iron and solder now.. Maybe I damaged it? I am using the other side of it with this install. Here is a picture of it. Any clue what this could be? Picture does not show the removed EXC1 & EXC5.
 

Attachments

  • 2A.JPG
    2A.JPG
    707 KB · Views: 68

LWK

Student
Joined
Apr 22, 2020
Messages
43
Reaction score
14
Location
California
Swapped for another Key. Fixed it. I messed up the other.
 

Galford

Student
Joined
Aug 7, 2019
Messages
52
Reaction score
19
Location
France
Hi all,
i need some help please because i'm a little bit confused , i'm not sure how to put the infinitkey cps2 on my SFZ-03 blackboard (suicid battery)
i tied to follow the installation but can't find a way for the blackboard :) :

Board revision : 97691A-4

here is my Cps2 :

https://ibb.co/T09P34N
https://ibb.co/rdcqZ98

Three questions :

1- should i solder the key on the CN1 connector ?

2- about jumpers :

game label : SZ3. How to identify which one from this list will match ?



SZ3A 10101000 sfz3a
SZ3B 10101001 sfa3b
SZ3E 10101010 sfa3
SZ3H 10101011 sfa3h
SZ3J 10101100 sfz3j
SZ3U 10101101 sfa3u


3- something else to do :) ?

Thanks a lot :)
 

idc

Enthusiast
Joined
Jun 14, 2015
Messages
125
Reaction score
183
Location
UK
Solder straight to the six-pin connector CN1, solder the jumper labelled “open for 93646B-5” closed, set jumpers for SZ3J 10101100.

Basically, follow the instructions for 93646B-6/7 boards. The only real difference is what is CN9 on a 93646B-6/7 board is CN1 on the all-in-one.
 

jewna

Student
Joined
Jul 8, 2018
Messages
43
Reaction score
22
Location
Centreville, VA
If it's a solid color screen it's probably suicided. I would recommend trying the Razoola CPS2 Suicide tester program rom to make sure. I have one cps2 board where even after writing keys to it, it stays on a blank screen. So using the Suicide Tester program rom will let you know if the error is just the keys aren't being written correctly or there's a further problem. One issue I have found with -3 and -4 CPS2 b boards is they sometimes require more 5v to program the keys... Can you test voltage at the jamma edge as well as on a chip and see where you're at? Should be 5v... if it's 4.8v at the chip that could be the problem.

Also, I would recommend practicing soldering on throw away boards a lot before ever doing a "production piece." So in the future if you need to solder something to through hole components, experiment on a throw away piece of tech first to get your method/temperature/process down.

There is not really a recommended rom reader/burner because it's all about what you need. If you only want to do CPS2 27C4096 type roms you can probably get away with a cheapy like the TL866II variants for around $50. If you want some slight future proofing you should look into the gq-4x4 for $100. If you really want to go big look at the BK burner or something else that is more pro. Eventually you might want to get something that does 48 pins.
Another poster with the same problem. My infinikeyed alpha 2 board worked for months after the install on arcade cabs and showed a blue suicide screen on my supergun. Low and behold the 5v node was low on my cps2 when on the supergun but fine on my cab. 4.3V is not enough for it to write the keys.... Thank you so much for the help.
 

Dk310

Enthusiast
Joined
Feb 13, 2017
Messages
214
Reaction score
109
Location
El Segundo, CA
Just got my chips. Looking forward to getting them installed! :)
 

kimbopman

Beginner
Joined
Aug 24, 2016
Messages
9
Reaction score
12
Location
USA
Infinikey is miraculous. I removed the stock maxell battery from my working Xmen COTA USA and soldered on the infinikey. No more worries about leaky batteries or changing batteries ever again. Great hardware design and simple to use! I actually bought a replacement battery a few years back but never installed it (thankfully the original battery never leaked).
PXL_20210223_030154108.jpg
 
Top