What's new

Trol

Professional
Joined
Jul 11, 2016
Messages
304
Reaction score
183
Location
Netherlands
This Naomi 2 mobo had a checkerboard screen and ran very slow.
Did the ram test and it hangs at IC9, this is a pc 100 ram chip also found on pc memory strips.

Went to my local dirty, smokey pc shop to dig through their boxes of old memory and didn't find the right rams...
So I ordered 5 from China and here's where the fun began... the first three gave me a black screen or the same checkerboard screen I had previously.
The fourth one was finally ok and the board booted as it should.

It still showed some minor glitches and carefully bending the board made them come and go, ram test sometimes showed IC20 bad.
Reflowed it and everything is ok now.

Soak testing it the next few days to see if it stays that way.
 
Did you try reflowing the memory at IC9 before replacing?
 
Hi Trol. I have the same issue on a Naomi 2 board. Slow checkerboard at boot and RAM test hangs at IC9.

I bought a PC100 RAM DIMM on ebay and replaced the RAM at IC9 but sadly have the same slow checkerboard issue and hang at IC9 on the RAM test.

Could it be the RAM underneath IC9 (at IC11S)? I searched online and other forum posts have said it's a GPU fault. Yours is the only post that gives a glimmer of hope.
 
Is the”new” ram exactly the same type as the old ram? Should be exactly the same.
I vaguely remember TylerDurden saying he raplaces ram by the pair, so ic 9 and 11 I think.
 
Thanks for the guidance AMS/Trol. Tonight I replaced IC11S on the flip side to IC9 and......................unfortunately the same problem with slow checkerboard and RAM test hang at IC9 :(

I also tried resoldering IC9 & IC11 replacing with another 2x RAM chips and experienced the same problem.

With either RAM chip off the board the Naomi 2 doesn't boot (black screen) so at least the RAM chips are good enough to allow booting and for N1 games to work.

I'll leave the RAM test running overnight. Perhaps it's just really slow to test and will eventually identify a bad RAM but if you have any more guidance to share I'd be super grateful


Edit - I let it run overnight and it was still stuck at IC9 with no result.
 
Last edited:
Just a last post for anyone that finds this thread in a search. I picked up another pc100 dimm and swapped ic9 and ic11 below again. Unfortunately it's still checkerboard and hangs at ic9 in tests :(

I actually swapped ic9 and ic11 twice more using up more chips from the dimm but all had the same issue.


So there must be another part failure that can cause this issue. Maybe one day someone far smarter than me will post a solution here :D
 
Finally fixed my "naomi 2 with checkerboard and RAM test hang at IC9". It turned out to be the RAM pair at IC116 and IC118.

IC118 and 116 removed.jpg




I bought a PC133 SDRAM DIMM on ebay with 16M chips on it.
Original RAM chips that turned out to be bad were "HYNIX 228A HY57V16110DTC-8". The replacement chips from the PC DIMM were "HYUNDAI HY57V1616100"


Swapped them both, powered it on to my surprise the checker board issues was fixed and RAM test completed:

Naomi working.jpg



No idea why the RAM test was freezing at IC9 when that RAM IC was fine all along and the problem was with the IC116 and IC118 pair. Seems the Naomi 2 RAM test has a bug in it.

I would also add if you have a Naomi 2 that is non-booting/black screen, try replacing IC9 and IC11 as the Naomi 2 will not boot with either of those 2 IC's removed/faulty.

Hopefully the above info will help someone in the future :)
 
Last edited:
Hi guys, very informative since i just got a Naomi 2 mother board with same issue same symptoms
- Checker pattern
- Slow startup
- RAM test hangs in IC9 (takes forever)

While i noticed other symptoms in mine
- After the slow boot up it shows ERROR 1 game inserted is not supported (even though there is no game cartrdige inserted)
- if i insert a game the boot screen starts with normal speed but flickers a lot, and when the game starts it shows graphics mixed with the checker pattern
- if i do a RAM test with cartridge inserted it performs normally and shows me IC22 is Bad and stops at IC23 saying test is over push any button !!!

well i want to know if ram test is not performing as it should and might be misleading as in the case MickyMac or should i check IC22 ?!
how hard is it to remove the ICs ? do they require too much heat ?

Thanks
 
In my case naomi 1 games played fine it was just the boot screen and naomi 2 games had the checkered screen/slow.

Removing the ICs is very easy with hot air. Much easier than through hole 74LS chips. The pin pitch is not too bad when soldering back on. Plenty of flux and a steady hand. If I can do it anyone can.

Try the latest bios from Mathew as it may be the old multibios has a bug in the ram test.

Also try touching up the pins on ic22 as well as the 116/118 pair.

Good luck!
 
Oh MickyMack, that was one fast response i am gratefull for that;
well i must admit that those through holes are a nightmare especially for thick board where the solder remain stuck inside...hhh.

i tried poking on the IC22 but nothing changed. also as you said those 116/118 might be the cause as well.
i saw a video on Youtube for replacing those ram ICs on naomi one (
View: https://www.youtube.com/watch?v=yvZibLSguXM
)
it seems that failing power supplies giving wrong 3.3v voltages are the reason of failure of these RAMs

Anyway i must first get the proper tools (solder tip (T12-K) and good flux) and then get to work.
thank you MickyMack.
 
Hi all,

i repaired a naomi 2 with the same problem, I replaced IC116 and iC118 and it worked. Problem was slow and stucked at IC09.

Now, i have other naomi 2 withe same issue, i have replaced 6 rams (IC9, IC11, IC116, IC118 and 2 more) and nothing changed.

Anyone have any idea ? Thanks in advance.
 
Well guys i have good news, i finally got my naomi to checker/slow down issue fixed.
Here is how it went...
When I run ram test without any game inserted the ram test get stuck on ic09, this seems to be the case always when a one or many of the gpus rams are bad.
À trick to run ram test without getting stuck in ic09 is to insert a naomi 1 game and run a ram test, but this only tests rams of the first gpu and ram of cpu. With this test you will make sûre that half of the rams are good or not. In my case ic22 was bad so i replace it and now no checker pattern was there when I played naomi 1 games. But still i had checker pattern and slow down in naomi 2 games... So since i have no way to know which ram of the second gpu is not working i had to do it the hard way, i started with where mickymack found issue (ic116 and ic118) but nothing changed now am Left with ic111, 113, 117, 115, 114, 112. So i started replacing one by one i noticed that when I removed à good one the checker pattern get worse with glitches plus the ram pattern, until i got to ic113 when I removed it and tested without it nothing changed, so i had high hope that this is the culprit, and indeed when I replaced it checker pattern is gone and ram test was all good..
Lessons learned
1-Checker pattern and slow down is related directly to gpu or gpu rams. And can be related to any of the rams, not ic118 or ic116 specifically.
2-To check first gpu rams including cpu rams insert a naomi 1 game and run test, this way you are removing half of the doubts.
3-ic106,107,108,109 are the ram chips of the interface chip that coordinates the work of both gpus on naomi 2 games. If one is bad it does not résult in checker patterns (if you see the picture i had ic106 testing as bad but I had no issues in start up).
4-if you want to quickly reset your naomi without hitting that power switch, just stop one of the gpu fans with your finger briefly. Your naomi will restart. This also shows that if one of the funs is not working the naomi wont start.
 

Attachments

  • DSC_1522.JPG
    DSC_1522.JPG
    121.1 KB · Views: 73
  • DSC_1514.JPG
    DSC_1514.JPG
    87.1 KB · Views: 78
  • DSC_1516.JPG
    DSC_1516.JPG
    164.9 KB · Views: 77
  • DSC_1513.JPG
    DSC_1513.JPG
    107.1 KB · Views: 79
Great tip on bypassing the IC9 hang using a Naomi 1 game.

The next issue is: how to identify which RAM is bad when you have a black screen.
 
I guess when you are having à black screen you should suspect cpu rams first, 4 of them, since it's the job of the cpu to start the system and do a check, of course given that your bios and rest of circuitry is working as they should.. It's so bad that no schematics are available for such a popular system.
 
Just got a Naomi 2 that was said to be working with the gd rom but it only plays Naomi 1 games fine and has a checkered ( it was green / black checkered, didn’t catch it in the pic ) pattern and is super slow in my initial d 3

I shoumd go and change out those ics mentioned first yeah?
 

Attachments

  • IMG_9576.jpeg
    IMG_9576.jpeg
    134.4 KB · Views: 24
  • IMG_9575.jpeg
    IMG_9575.jpeg
    140.7 KB · Views: 24
Just got a Naomi 2 that was said to be working with the gd rom but it only plays Naomi 1 games fine and has a checkered ( it was green / black checkered, didn’t catch it in the pic ) pattern and is super slow in my initial d 3

I shoumd go and change out those ics mentioned first yeah?
hey read my post you might have the exact same issue as mine

Well guys i have good news, i finally got my naomi to checker/slow down issue fixed.
Here is how it went...
When I run ram test without any game inserted the ram test get stuck on ic09, this seems to be the case always when a one or many of the gpus rams are bad.
À trick to run ram test without getting stuck in ic09 is to insert a naomi 1 game and run a ram test, but this only tests rams of the first gpu and ram of cpu. With this test you will make sûre that half of the rams are good or not. In my case ic22 was bad so i replace it and now no checker pattern was there when I played naomi 1 games. But still i had checker pattern and slow down in naomi 2 games... So since i have no way to know which ram of the second gpu is not working i had to do it the hard way, i started with where mickymack found issue (ic116 and ic118) but nothing changed now am Left with ic111, 113, 117, 115, 114, 112. So i started replacing one by one i noticed that when I removed à good one the checker pattern get worse with glitches plus the ram pattern, until i got to ic113 when I removed it and tested without it nothing changed, so i had high hope that this is the culprit, and indeed when I replaced it checker pattern is gone and ram test was all good..
Lessons learned
1-Checker pattern and slow down is related directly to gpu or gpu rams. And can be related to any of the rams, not ic118 or ic116 specifically.
2-To check first gpu rams including cpu rams insert a naomi 1 game and run test, this way you are removing half of the doubts.
3-ic106,107,108,109 are the ram chips of the interface chip that coordinates the work of both gpus on naomi 2 games. If one is bad it does not résult in checker patterns (if you see the picture i had ic106 testing as bad but I had no issues in start up).
4-if you want to quickly reset your naomi without hitting that power switch, just stop one of the gpu fans with your finger briefly. Your naomi will restart. This also shows that if one of the funs is not working the naomi wont start.
 
Back
Top