What's new
@snake390 Please try this new version of ttxshell.

Instructions:
  • Remove the drive from your TTX
  • Mount your drive on your PC using your favourite tools.
  • On the partition named: TTXMulti[C], navigate to the directory \WINDOWS\system32
  • Rename the file Ttxshell.exe to OldTtxshell.exe
  • Copy in the new verstion of Ttxshell.exe
  • Unmount the drive and connect it to your TTX again
Code:
4.8.4 : Simplified mount code
        Added retry if opening of COM2 fails

4.8.3 : Added more logging

4.8.2 : Added logging mechanism.
        If e:\ttxshell.txt exists the program log will be appended to this file.
        All log entries will be appended to the existing file

4.8.1 : Refactored all disk mounting

4.7.3 : adjusted delay in JVS addressing
        increased waitlength for d:\ to become ready
        [debug]
        Hitting enter on an error message will invoke: cmd.exe

4.7.2 : Menu crash patch.
 

Attachments

  • ttxshell_4.8.4.zip
    8.1 KB · Views: 52
@snake390 Please try this new version of ttxshell.

Instructions:
  • Remove the drive from your TTX
  • Mount your drive on your PC using your favourite tools.
  • On the partition named: TTXMulti[C], navigate to the directory \WINDOWS\system32
  • Rename the file Ttxshell.exe to OldTtxshell.exe
  • Copy in the new verstion of Ttxshell.exe
  • Unmount the drive and connect it to your TTX again
Code:
4.8.4 : Simplified mount code
        Added retry if opening of COM2 fails

4.8.3 : Added more logging

4.8.2 : Added logging mechanism.
        If e:\ttxshell.txt exists the program log will be appended to this file.
        All log entries will be appended to the existing file

4.8.1 : Refactored all disk mounting

4.7.3 : adjusted delay in JVS addressing
        increased waitlength for d:\ to become ready
        [debug]
        Hitting enter on an error message will invoke: cmd.exe

4.7.2 : Menu crash patch.


Hello good morning

Thanks for the advice after doing the process @rtw I see the error several times:

1713837784380.png


The com2 error no longer appears but now it appears several times and after entering several times the game starts.

additional question:
How do I configure the game buttons?

How to access this menu?
1713838118716.png


Thanks again
 

Attachments

  • 1713837755260.png
    1713837755260.png
    683.8 KB · Views: 32
Did you set your CRT to VGA mode? Some monitors can not auto switch between resolutions, so check to see if your CRT has a dip switch. Also, the bottom VGA port will work on a standard resolution display. I've tested a Taito Type X on my Astrocity. Make sure you only plug the vga cable into the VGA port only, to make it boot up in standard resolution. At least that's what I noticed from my experience.
Hello, thanks for your contribution
I already did what you told me but when I connect it directly to the VGA I don't get an image either on the CRT or on the monitor to get an image I have to connect it to the DVI with a pad then it starts if it gives me an image on the VGA
 
Hello good morning

Thanks for the advice after doing the process @rtw I see the error several times:

1713837784380.png


The com2 error no longer appears but now it appears several times and after entering several times the game starts.

additional question:
How do I configure the game buttons?

How to access this menu?
1713838118716.png


Thanks again

Update I no longer see errors but now select Kof 98 it starts with errors but it starts the game directly

Question after starting a game, how do I return to the main Multi menu?
 
Update I no longer see errors but now select Kof 98 it starts with errors but it starts the game directly

Question after starting a game, how do I return to the main Multi menu?
by pushish the black button from backside of TTX1 unit you will reset the system and you will return in the Multi menu screen ☝🏻 or classical , power off the unit and power on ✌🏻

also , no offence mr. @snake390 & @snake1392 , on the forum is this section (will be nice to write some words there too) : https://www.arcade-projects.com/forums/introductions.56/
IMG_0181.jpeg
 
Last edited:
@snake390 , have you got two accounts ? :)

I don't really understand what is going on here. Please take a video of the system starting so I can see what is going on.

With the new version of ttxshell your background image should be red, but I do not see that in your pictures.
 
Hello good morning
If I hadn't realized, I was logging in with another browser. Sorry, I already closed the other account in the afternoon. I'll send a video to show you.
 
by pushish the black button from backside of TTX1 unit you will reset the system and you will return in the Multi menu screen ☝🏻 or classical , power off the unit and power on ✌🏻

also , no offence mr. @snake390 & @snake1392 , on the forum is this section (will be nice to write some words there too) : https://www.arcade-projects.com/forums/introductions.56/
IMG_0181.jpeg

Hello
Thanks for your help, I thought there was another way

I already made the post in the forum that you recommend
 
@snake390 , have you got two accounts ? :)

I don't really understand what is going on here. Please take a video of the system starting so I can see what is going on.

With the new version of ttxshell your background image should be red, but I do not see that in your pictures.

Hello

I add video of operation

I explain a little, the emulator loads well without com2 errors but in the loading process some errors appear but in the end it starts when trying to load some game, anyone loads only the kof98, I try to restart it from the back button as they explain but now it loads directly Shouldn't kof 98 return to the menu?

Additionally, if you see the video I have to change the port on the video card because if I leave it in the DVI port the image is lost. What I do is transfer it to the VGA port so that it gives me an image

Thanks for your comments

View: https://www.youtube.com/watch?v=GA6XOd9r0So&ab_channel=oscarAlexanderPinillaGuevara
 
Hi, I watched your video and I am a bit confused. It looks like something is wrong with your graphics card ?

Can you try to start the game "gpu_test" so we can see what kind of graphics adapter you have ?
 
Hola, vi tu video y estoy un poco confundido. ¿Parece que hay algún problema con tu tarjeta gráfica?

¿Puedes intentar iniciar el juego "gpu_test" para que podamos ver qué tipo de adaptador de gráficos tienes?
I added my video configuration but enabled ttxshell_4.7.2 since it did not open with ttxshell_4.8.4
1713974097991.jpeg
 
@snake390 thank you for the GPU information, you have the correct GPU.

What kind of SATA disk are you using ?

To be honest I do not understand what is going on here.

When you use ttxshell 4.8.4 the menu does not appear or you cannot navigate the menu ?

Because in your video the menu appears with 4.8.4 ....
 
@snake390 thank you for the GPU information, you have the correct GPU.

What kind of SATA disk are you using ?

To be honest I do not understand what is going on here.

When you use ttxshell 4.8.4 the menu does not appear or you cannot navigate the menu ?

Because in your video the menu appears with 4.8.4 ....

hello

What happens is that when I go to ttxshell 4.8.4, sometimes the menu opens but it only runs kof 98, even if I choose any other game to show you the image of the gpu, I have to go back to ttxshell_4.7.2

I have a 2.5 128 Xue s500 series SSD
 
Last edited:
Both of those should work with the TTXMulti.

Please try the SEGA one to rule out any issues with the Capcom.

When you say that 4.7.2 works, it means you are using a PS2 keyboard to remove the error message ?

If you use 4.8.4 does the selection menu appear ?
 
Both of those should work with the TTXMulti.

Please try the SEGA one to rule out any issues with the Capcom.

When you say that 4.7.2 works, it means you are using a PS2 keyboard to remove the error message ?

If you use 4.8.4 does the selection menu appear ?
When you say 4.7.2 works, does that mean you are using a PS2 keyboard to eliminate the error message?

*Yeah

If you use 4.8.4 does the selection menu appear?

*If the problem appears it is that when selecting any game only kof 98 is executed, for that reason I went back to 4.7.2 to show you the
gpu image
 
Thanks for the info.

Tell me, if you use 4.8.4 does the game selection menu appear correctly ?

If it appears, can you go up and down ?
 
@snake390 gracias por la información de la GPU, tienes la GPU correcta.

¿Qué tipo de disco SATA estás usando?

Para ser honesto, no entiendo lo que está pasando aquí.

Cuando usa ttxshell 4.8.4, ¿el menú no aparece o no puede navegar por el menú?

Porque en tu vídeo aparece el menú con 4.8.4....
Hola, cómo estás

lo siento después de unas vacaciones forzadas

mira mi disco es este dd state solid de 128 gb

1715660375624.png

Voy a intentar reformatear y colocar directamente el tthsell que me enviaste.

muchas gracias y perdon por la demora


Lo que pasa es que cuando intento seleccionar un juego siempre aparece solo Kof 98, pero en la lista están los demás juegos. Esto sucede cuando selecciono cualquier juego.
 
Back
Top