What's new
Yeah, I've downloaded the old and new rom packs and put them on different memory cards. Re: Level shifters - of course, I'll have a search.

Thanks for the responsiveness, by the way. It's awesome advice.
 
I hope everyone is doing great.

I have a Darksoft CPS2 kit from 2015 and would like to know how to update the firmware.

I want to avoid soldering and I am fine with playing decrypted CPS2 games.

I have attached a picture of the Darksoft CPS2 multi kit. How do I update the firmware and where can I get the firmware update files? My goal is to also be able to play some of the CPS1.5 games that are made available through the firmware update.

Looking forward to hearing back from all of you.
 

Attachments

  • 6C65666D-292B-4C2E-A38B-2B53E777B5DF.jpeg
    6C65666D-292B-4C2E-A38B-2B53E777B5DF.jpeg
    411.6 KB · Views: 49
You don't need to update the firmware to run the CPS1.5 to CPS2 conversions since those conversions don't use encryption - just add the files to your SD card.

The only benefit to updating your firmware is to run the original encrypted Capcom ROMs for the officially released CPS2 games.

That said, if you want to update your firmware, there's instructions and files here:
https://www.arcade-projects.com/thr...mware-for-a-launch-cps2-multi.6013/post-90046
 
@ShootTheCore Thank you so much for your help. I think I need to reformat my sd card. When I scroll through the games I get funky symbols.

It’s so great to see you here. I miss Smokesmonster’s discord.

I think most of us are on Bob’s discord now.
 
@ShootTheCore Thank you so much for your help. I think I need to reformat my sd card. When I scroll through the games I get funky symbols.

It’s so great to see you here. I miss Smokesmonster’s discord.

I think most of us are on Bob’s discord now.

I'm on Bob's Discord but mostly as a lurker. There's so many Discord channels these days that I can't keep up with any of them. :D
 
@ShootTheCore
Thanks for the help. I was able to get Punisher running. I copied over Street Fighter 2 CE and the other cps1 Street fighter. When I try to load that game I immediately get the message All Done: Operation Failed. How can I fix this?
 
The quick load points to bad roms in the game directory. Wrong format maybe or corrupt
 
@Darksoft @djsheep @Mitsurugi-w
The first time I when I loaded the games I had those funky symbols and most games didn’t load. So I formatted the sd card and loaded the games including the punisher. When that game worked I added SF2CE and ST2HF. Those are not working yet. I can maybe go into the folder and and delete any extra symbols.
 
Try with 2-3 different cards, the smaller in size the better. Original cards from reliable source will work well, the other ones, hard to say. Also make sure it's SDHC and not SDXC. Post a picture of the microSD if you can.
 
When that game worked I added SF2CE and ST2HF.
Sounds like you're copying onto the SD card multiple times. I've had issues in the past adding extra games to a card that already had games on it.
Now when I add a game, I format the card and add all previous games plus the extra game in one go.
 
@Darksoft yeah it’s the original 8 gb card you included when I got it from you.

@wigsplitta I think you are right. I previously had the original game set Darksoft included on my sd card and added the punisher to it. That didn’t work. Then I formatted it and copied the the original rom set and punisher afterwards. When punisher worked, I then copied those two cps1 games. I will try your method this time with all the roms.

Also are there other cps1 - 1.5 conversions for the Darksoft Multikit?
 
@wigsplitta that did the trick. I reformatted the Samsung SDHC 8 GB Micro SD card loaded all the games and Now_Play files at once. I am now able to play SF2 CE and HF as well as Punisher. I enjoy this Darksoft CPS2 Multikit so much in the Astro City. I really don’t want to hook up a Mister to the candy cab yet.

Thank you everyone for the help.
 
EDIT: I tried a 3rd SD card, following the same instructions, and it works. I wish I could be more helpful, but I'm just not sure what specifically was different. Either way, I've been cycling through games without issue now and am loving the system!

So I booted up, flashed a game from the LCD, annnd green/black screen. I double checked my overall setup with both my supergun and a candy, and also checked with known working boards to ensure that wasn't the issue.

Using the HSS instructions, this is where I am:
- I shorted EXC5 prior to installation for ~15 seconds. I then did this two more times from different angles to ensure I was getting good contact on all 3 pins
- I checked the multi pins to ensure they were not bent or broken prior to installation, and did not observe any issues. I'm hoping to leave "remove multi boards and check again" for last
- pictures are attached regarding board installation, it appears everything is fully seated and in the correct locations
- no key writing wires are installed, I'm instead using the "Darksoft CPS-2 Decrypted Set"
- I have not updated or changed the firmware at all
- I tried another SD card, both brand new with no change (SDHC, 8GB Gigastone)

EDIT: I did remove an Infinikey prior to installation, if that helps.
 

Attachments

  • IMG20230111162905.jpg
    IMG20230111162905.jpg
    215.8 KB · Views: 46
  • CPS22.PNG
    CPS22.PNG
    497.4 KB · Views: 51
Last edited:
Can someone send me a dump of their microSD created in a Mac(small one if possible and packed). I'm gonna have a look at this issue hopefully for good.
 
If the ZIP file containing the roms is extracted from a Mac, you have to clean the dot files with Dotcleaner for example.

Each extracted file had its own dot file before cleaning.

For me, these hidden files generated a black screen after a game was loaded.
 
As me, erasing the dot files should resolve your probems.

It’s better to prepare the micro SD card with Windows.
 
Back
Top