What's new

nonosto

Grand Master
Joined
Jun 5, 2018
Messages
1,729
Reaction score
393
Location
FRANCE
do you have the map about connector I will wire it directly:

ez-pad10.jpg
 

RealMFnG

Legendary
Joined
Mar 27, 2016
Messages
4,743
Reaction score
4,054
Location
Northern California
Also a tip about the order of operations for assembly. You can add all of the SMD components first, but make sure you program the Home/Select emulation chip before you add the button remapping chip. If both are installed before programming the Home/Select chip you will get bus conflicts on the ISP bus and the emulation chip will fail to program. In the event that you accidentally do this anyway, you can still program the Home/Select chip, but you will have to have the JAMMAizer plugged into a cabinet or supergun to power the button remapping chip so it's I/O is floating and won't interfere with your programming operation.
Hey @Arthrimus, if you ever see this post, I am struggling with programming the ATTINY87. Using my Xeltek 610p and an SOIC adapter to program it externally doesn't work right. I am not able to activate the button mapping features.

The question are:
  1. What application are you using to perform the programming of the ATTINY87 in circuit? I am guessing you are using AVRDUDESS based upon your post here for programming the ATMEGA and that you mentioned to me that you use USBAsp.
  2. If not using AVRDUDESS, are you building a sketch in Arduino IDE?
    1. A screenshot of the settings you are using in whatever ap you are using would be tremendously helpful
    2. External or Internal clock?
    3. What frequency?
    4. Fuse settings?
  3. Do the traces get cut on the button mapper before or after the ATTINY87 is programmed?
Sometimes I get errors in AVRDUDESS using USBAsp where the chip can't be detected. Possible that I fried the ATTINY87. No big deal as I have a few of those handy. Just really struggling with programming the ATTINY87. And the ATMEGA is not inserted into the dip socket as I am attempting this.

One a side note, I think I have tried just about everything. Last thing to try is on a virgin board with SMD components installed without the button mapper traces cut. That is the only thing I can think of that could be holding me up since I have tried just about everything else to program the ATTINY87.
 
Last edited:
Top